summaryrefslogtreecommitdiffstats
path: root/recipes-demo/navigation/tbtnavi_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-12-17 19:49:16 +0100
commit6a03aab746284f041af307c0f743b08450ff440f (patch)
tree0e439f515be26cbc1e7c9cab9c264a7ff9d68837 /recipes-demo/navigation/tbtnavi_git.bb
parentb97d48fb17f8fcd49eb513a331ccf909a35f2014 (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo/navigation/tbtnavi_git.bb')
-rw-r--r--recipes-demo/navigation/tbtnavi_git.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes-demo/navigation/tbtnavi_git.bb b/recipes-demo/navigation/tbtnavi_git.bb
index 240a9e0c4..2a35c6d7f 100644
--- a/recipes-demo/navigation/tbtnavi_git.bb
+++ b/recipes-demo/navigation/tbtnavi_git.bb
@@ -41,9 +41,9 @@ inherit meson systemd pkgconfig update-alternatives
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
do_install:append() {
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
- install -D -m 0644 ${WORKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
+ install -D -m 0644 ${UNPACKDIR}/kvm.conf ${D}${systemd_system_unitdir}/${BPN}.service.d/kvm.conf
# Currently using default global client and CA certificates
# for KUKSA.val SSL, installing app specific ones would go here.
@@ -53,10 +53,10 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/tbtnavi
- install -m 0644 ${WORKDIR}/tbtnavi.conf ${D}${sysconfdir}/xdg/AGL/tbtnavi.conf.default
- install -m 0644 ${WORKDIR}/tbtnavi.conf.kvm-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/tbtnavi.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/tbtnavi.token ${D}${sysconfdir}/xdg/AGL/tbtnavi/
+ install -m 0644 ${UNPACKDIR}/tbtnavi.conf ${D}${sysconfdir}/xdg/AGL/tbtnavi.conf.default
+ install -m 0644 ${UNPACKDIR}/tbtnavi.conf.kvm-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/tbtnavi.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/tbtnavi.token ${D}${sysconfdir}/xdg/AGL/tbtnavi/
}
ALTERNATIVE_LINK_NAME[tbtnavi.conf] = "${sysconfdir}/xdg/AGL/tbtnavi.conf"