summaryrefslogtreecommitdiffstats
path: root/recipes-demo/navigation
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 15:18:49 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-11-03 22:43:56 +0100
commit1b72a0f90fa7d1b45eb1017629cc83dcd8971c48 (patch)
treedecc406f376b968d90fade3c321777e068a8c00e /recipes-demo/navigation
parent94a051785cdb588bc3a475a5490f1f286176d646 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - recipes-apis : all agl-service-* - recipes-demos: all demo apps but homescreen - non-essential configurations Todo: We need to bring-back the html5 image in a follow-up w/o ties into the old framework. v2: kept WAM + Chromium recipes for reference v3: rebased Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I58075f5f1e477106a1aad3d2171a0904bf0cb16e
Diffstat (limited to 'recipes-demo/navigation')
-rw-r--r--recipes-demo/navigation/ondemandnavi-config/naviconfig.ini9
-rw-r--r--recipes-demo/navigation/ondemandnavi-config_1.0.bb21
-rw-r--r--recipes-demo/navigation/ondemandnavi_git.bb31
-rw-r--r--recipes-demo/navigation/poiapp-api-key_1.0.bb21
-rw-r--r--recipes-demo/navigation/poiapp/0001-add-display-permission.patch21
-rw-r--r--recipes-demo/navigation/poiapp_git.bb23
-rw-r--r--recipes-demo/navigation/tbtnavi_git.bb38
7 files changed, 0 insertions, 164 deletions
diff --git a/recipes-demo/navigation/ondemandnavi-config/naviconfig.ini b/recipes-demo/navigation/ondemandnavi-config/naviconfig.ini
deleted file mode 100644
index f99c4483..00000000
--- a/recipes-demo/navigation/ondemandnavi-config/naviconfig.ini
+++ /dev/null
@@ -1,9 +0,0 @@
-{
- "mapAccessToken":"MAPBOX_ACCESS_TOKEN",
- "speed":60,
- "interval":100,
- "latitude":36.1363,
- "longitude":-115.151,
- "mapStyleUrls":"styles/v1/mapbox/streets-v11",
- "enableOSM":true
-}
diff --git a/recipes-demo/navigation/ondemandnavi-config_1.0.bb b/recipes-demo/navigation/ondemandnavi-config_1.0.bb
deleted file mode 100644
index 212971f2..00000000
--- a/recipes-demo/navigation/ondemandnavi-config_1.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "AGL Reference On Demand Navigation application config."
-DESCRIPTION = "Config file for on-demand navigation app."
-HOMEPAGE = "https://github.com/YoshitoMomiyama/aglqtnavigation.git"
-SECTION = "apps"
-LICENSE = "Proprietary"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-
-SRC_URI = "file://naviconfig.ini \
- "
-
-inherit allarch
-
-MAPBOX_ACCESS_TOKEN ?= "Please set mapbox access token"
-
-do_compile[noexec] = "1"
-
-do_install () {
- install -D -m 644 ${WORKDIR}/naviconfig.ini ${D}${sysconfdir}/naviconfig.ini
- sed -i -e 's/MAPBOX_ACCESS_TOKEN/${MAPBOX_ACCESS_TOKEN}/' ${D}${sysconfdir}/naviconfig.ini
-}
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
deleted file mode 100644
index 5264ba63..00000000
--- a/recipes-demo/navigation/ondemandnavi_git.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-SUMMARY = "Navigation application."
-DESCRIPTION = "AGL demonstration Navigation application based on QtLocation widget."
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
-SECTION = "apps"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-
-DEPENDS = "qtquickcontrols2 qtlocation libqtappfw"
-
-PV = "1.0+git${SRCPV}"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
-
-S = "${WORKDIR}/git"
-
-inherit qmake5 aglwgt pkgconfig
-
-RDEPENDS:${PN} += " \
- qtlocation \
- flite \
- libqtappfw \
- openjtalk \
- gstreamer1.0 \
- ondemandnavi-config \
- agl-service-navigation \
-"
-
-RPROVIDES:${PN} = "virtual/navigation"
-
diff --git a/recipes-demo/navigation/poiapp-api-key_1.0.bb b/recipes-demo/navigation/poiapp-api-key_1.0.bb
deleted file mode 100644
index d353d7dd..00000000
--- a/recipes-demo/navigation/poiapp-api-key_1.0.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "AGL Reference POI application API key."
-DESCRIPTION = "Preload the API key for the AGL POI application."
-HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
-SECTION = "apps"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM="file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-
-inherit allarch
-
-do_fetch[noexec] = "1"
-do_unpack[noexec] = "1"
-do_compile[noexec] = "1"
-
-POIAPP_CLIENT_ID ?= ""
-POIAPP_API_KEY ?= ""
-
-do_install () {
- install -d ${D}${sysconfdir}
- echo "${POIAPP_CLIENT_ID}" > ${D}${sysconfdir}/poikey
- echo "${POIAPP_API_KEY}" >> ${D}${sysconfdir}/poikey
-}
diff --git a/recipes-demo/navigation/poiapp/0001-add-display-permission.patch b/recipes-demo/navigation/poiapp/0001-add-display-permission.patch
deleted file mode 100644
index 25a8fc31..00000000
--- a/recipes-demo/navigation/poiapp/0001-add-display-permission.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Add display permission
-
-Add display permission required to work with the running as non-root
-change for applications.
-
-Upstream-Status: pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/config.xml.in b/config.xml.in
-index b8cfccd..bec206d 100755
---- a/config.xml.in
-+++ b/config.xml.in
-@@ -13,6 +13,7 @@
- <feature name="urn:AGL:widget:required-permission">
- <param name="urn:AGL:permission::public:no-htdocs" value="required" />
- <param name="http://tizen.org/privilege/internal/dbus" value="required" />
-+ <param name="urn:AGL:permission::public:display" value="required" />
- </feature>
- <license>GPL</license>
- </widget>
diff --git a/recipes-demo/navigation/poiapp_git.bb b/recipes-demo/navigation/poiapp_git.bb
deleted file mode 100644
index 08e174f7..00000000
--- a/recipes-demo/navigation/poiapp_git.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-SUMMARY = "AGL Reference POI application."
-DESCRIPTION = "This application provides the function of destination search to AGL. It uses the API provided by AGL Reference Navigation. This application uses yelp WebAPI."
-HOMEPAGE = "https://github.com/AGLExport/genivi-navi-yelp-client"
-SECTION = "apps"
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=4ee23c52855c222cba72583d301d2338"
-
-DEPENDS = " \
- qtbase \
- json-c \
- libhomescreen \
- libqtappfw \
-"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
-
-S = "${WORKDIR}/git"
-
-inherit cmake_qt5 pkgconfig aglwgt
-
-RDEPENDS:${PN} = "qtbase libqtappfw"
diff --git a/recipes-demo/navigation/tbtnavi_git.bb b/recipes-demo/navigation/tbtnavi_git.bb
deleted file mode 100644
index a4f22545..00000000
--- a/recipes-demo/navigation/tbtnavi_git.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-SUMMARY = "AGL Reference Navigation Cluster Streaming application"
-DESCRIPTION = "Demo AGL turn by turn cluster navigation application based on QtLocation widget."
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/tbtnavi"
-SECTION = "apps"
-
-LICENSE = "Apache-2.0 & ISC & BSD-3-Clause & BSL-1.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
- file://LICENSE.mapbox-cheap-ruler-cpp;md5=761263ee6bdc98e8697d9fbc897021ba \
- file://LICENSE.mapbox-geometry.hpp;md5=6e44f5d6aeec54f40fc84eebe3c6fc6c \
- file://LICENSE.mapbox-variant;md5=79558839a9db3e807e4ae6f8cd100c1c \
- file://include/mapbox/recursive_wrapper.hpp;beginline=4;endline=13;md5=cd3341aae76c0cf8345935abd20f0051 \
-"
-
-DEPENDS = " \
- qtbase \
- qtquickcontrols2 \
- qtlocation \
- libqtappfw \
- wayland-native \
- qtwayland-native \
-"
-
-PV = "1.0+git${SRCPV}"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
-
-S = "${WORKDIR}/git"
-
-inherit qmake5 aglwgt pkgconfig
-
-RDEPENDS:${PN} += " \
- qtlocation \
- ondemandnavi-config \
- agl-service-navigation \
- agl-service-signal-composer \
- libqtappfw \
-"