summaryrefslogtreecommitdiffstats
path: root/recipes-demo/qtquickcontrols2-agl-style
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-11-22 17:58:54 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-25 11:25:41 +0000
commit24e55fccab51e217d4452968b082f0531a05fcb5 (patch)
treee3e0dd1e9dfed15c9f94ec0af20f2b6590b86845 /recipes-demo/qtquickcontrols2-agl-style
parent275de1d5dceae84c872e354f2f8b15ad275f97ae (diff)
Update Qt demo app SRCREVs
Update Qt demo app SRCREVs to pick up their Qt6 updates, and drop the now unnecssary Qt6 patches. Also, the MapBox configuration support has been removed from the ondemandnavi-config recipe, as that backend is no longer supported by QtLocation in Qt6. Bug-AGL: SPEC-5294 Change-Id: Ib44c6be83c3d4654c9ed5adffa3e9d34057eb2ae Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30543 ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-demo/qtquickcontrols2-agl-style')
-rw-r--r--recipes-demo/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style/0001-Migrate-to-Qt-6.patch71
-rw-r--r--recipes-demo/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb6
2 files changed, 2 insertions, 75 deletions
diff --git a/recipes-demo/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style/0001-Migrate-to-Qt-6.patch b/recipes-demo/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style/0001-Migrate-to-Qt-6.patch
deleted file mode 100644
index f00cb1420..000000000
--- a/recipes-demo/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style/0001-Migrate-to-Qt-6.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 6581ce20312ee15f35e00e29e363270616e96359 Mon Sep 17 00:00:00 2001
-From: Indivara Weerasuriya <1806262-indivara@users.noreply.git.qt.io>
-Date: Wed, 24 Jul 2024 09:37:08 +0900
-Subject: [PATCH] Migrate to Qt 6
-
----
- imports/qtquickcontrols2aglstyle/ProgressBar.qml | 2 +-
- imports/qtquickcontrols2aglstyle/Slider.qml | 2 +-
- imports/qtquickcontrols2aglstyle/qmldir | 10 ++++++++++
- .../qtquickcontrols2aglstyle.pro | 4 ++--
- 4 files changed, 14 insertions(+), 4 deletions(-)
- create mode 100644 imports/qtquickcontrols2aglstyle/qmldir
-
-diff --git a/imports/qtquickcontrols2aglstyle/ProgressBar.qml b/imports/qtquickcontrols2aglstyle/ProgressBar.qml
-index 6d5e3ae..fca0b8a 100644
---- a/imports/qtquickcontrols2aglstyle/ProgressBar.qml
-+++ b/imports/qtquickcontrols2aglstyle/ProgressBar.qml
-@@ -16,7 +16,7 @@
-
- import QtQuick 2.6
- import QtQuick.Templates 2.0 as T
--import QtGraphicalEffects 1.0
-+import Qt5Compat.GraphicalEffects
-
- T.ProgressBar {
- id: control
-diff --git a/imports/qtquickcontrols2aglstyle/Slider.qml b/imports/qtquickcontrols2aglstyle/Slider.qml
-index 5b6a495..02f4555 100644
---- a/imports/qtquickcontrols2aglstyle/Slider.qml
-+++ b/imports/qtquickcontrols2aglstyle/Slider.qml
-@@ -16,7 +16,7 @@
-
- import QtQuick 2.6
- import QtQuick.Templates 2.0 as T
--import QtGraphicalEffects 1.0
-+import Qt5Compat.GraphicalEffects
-
- T.Slider {
- id: root
-diff --git a/imports/qtquickcontrols2aglstyle/qmldir b/imports/qtquickcontrols2aglstyle/qmldir
-new file mode 100644
-index 0000000..e4e4417
---- /dev/null
-+++ b/imports/qtquickcontrols2aglstyle/qmldir
-@@ -0,0 +1,10 @@
-+module AGL
-+ApplicationWindow 1.0 ApplicationWindow.qml
-+Button 1.0 Button.qml
-+Label 1.0 Label.qml
-+Page 1.0 Page.qml
-+ProgressBar 1.0 ProgressBar.qml
-+Slider 1.0 Slider.qml
-+Switch 1.0 Switch.qml
-+TextField 1.0 TextField.qml
-+Tumbler 1.0 Tumbler.qml
-\ No newline at end of file
-diff --git a/imports/qtquickcontrols2aglstyle/qtquickcontrols2aglstyle.pro b/imports/qtquickcontrols2aglstyle/qtquickcontrols2aglstyle.pro
-index 5a34485..ba24e9d 100644
---- a/imports/qtquickcontrols2aglstyle/qtquickcontrols2aglstyle.pro
-+++ b/imports/qtquickcontrols2aglstyle/qtquickcontrols2aglstyle.pro
-@@ -1,8 +1,8 @@
- TEMPLATE = aux
-
--DISTFILES = *.qml images
-+DISTFILES = *.qml images qmldir
-
- files.files = $$DISTFILES
--files.path = $$PREFIX$$[QT_INSTALL_QML]/QtQuick/Controls.2/AGL
-+files.path = $$PREFIX$$[QT_INSTALL_BINS]/AGL
-
- INSTALLS += files
diff --git a/recipes-demo/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb b/recipes-demo/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb
index 3ccee1210..75aed3aaf 100644
--- a/recipes-demo/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb
+++ b/recipes-demo/qtquickcontrols2-agl-style/qtquickcontrols2-agl-style_git.bb
@@ -7,10 +7,8 @@ DEPENDS = "qtdeclarative"
PV = "1.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl-style;protocol=https;branch=${AGL_BRANCH} \
- file://0001-Migrate-to-Qt-6.patch \
- "
-SRCREV = "c02692a3c20d9aed1192137a67d5be882c60e71f"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtquickcontrols2-agl-style;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "4059077eb23b6338e153036c602972cbbb46cbb8"
S = "${WORKDIR}/git"