summaryrefslogtreecommitdiffstats
path: root/recipes-demo/radio/radio_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-07-27 17:02:54 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-27 19:39:16 -0400
commit731adc93b2fed74bc4410dff510fb019d10f253f (patch)
tree77f17ab8b7b906a288d84f99f2cb4cde6fa537ff /recipes-demo/radio/radio_git.bb
parentf22d415e4b1290cbba736df7d4cafa043dc8f8f2 (diff)
Updates for application enumeration via systemd units
Update application recipes to use the new agl-app.bbclass to install the now required by applaunchd systemd template unit instances. The previously used .desktop files have been removed, and it is believed that the required configuration with respect to application display names has been captured in the new agl-app configuration variables. Bug-AGL: SPEC-4466 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I2925a68f911646c287bc7128bb0e5f43d55ce7bf
Diffstat (limited to 'recipes-demo/radio/radio_git.bb')
-rw-r--r--recipes-demo/radio/radio_git.bb10
1 files changed, 2 insertions, 8 deletions
diff --git a/recipes-demo/radio/radio_git.bb b/recipes-demo/radio/radio_git.bb
index fcbbd634..22b22010 100644
--- a/recipes-demo/radio/radio_git.bb
+++ b/recipes-demo/radio/radio_git.bb
@@ -19,7 +19,7 @@ SRCREV = "f48bb2aab34273bd5b3cc1f9f9d88afbfb231d6b"
S = "${WORKDIR}/git"
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
# ALS, CES, FOSDEM available
AGL_RADIO_PRESETS_LOCALE ?= "CES"
@@ -31,12 +31,6 @@ do_install:append() {
install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
}
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
- sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/radio.desktop
- echo "DBusActivatable=true" >> ${D}${datadir}/applications/radio.desktop
-}
-
-FILES:${PN} += "${sysconfdir}/xdg/AGL/* ${datadir}/icons/"
+FILES:${PN} += "${sysconfdir}/xdg/AGL/*"
RDEPENDS:${PN} += "libqtappfw"