summaryrefslogtreecommitdiffstats
path: root/recipes-demo/webapp-samples/html5-aquarium_git.bb
diff options
context:
space:
mode:
authorRoger Zanoni <rzanoni@igalia.com>2022-11-09 14:31:36 +0100
committerHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2023-01-15 04:20:18 +0000
commitab99f9c50797b07b069433ce6a78dcad2b6702d3 (patch)
tree178f21a9152d619c2c44016e27331c438b6069a0 /recipes-demo/webapp-samples/html5-aquarium_git.bb
parent677b61333546873cc1efab630901999760e954bb (diff)
Restore webapp samples
The desktop files aren't used anymore, change the recipes to use appinfo.json instead. Bug-AGL: SPEC-4605 Signed-off-by: Roger Zanoni <rzanoni@igalia.com> Change-Id: Ie03aef155217f59bb6363f18b2781adbacc93786 (cherry picked from commit 7f3038e5efb5fed78457a5855560a3ae8912f783)
Diffstat (limited to 'recipes-demo/webapp-samples/html5-aquarium_git.bb')
-rw-r--r--recipes-demo/webapp-samples/html5-aquarium_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-demo/webapp-samples/html5-aquarium_git.bb b/recipes-demo/webapp-samples/html5-aquarium_git.bb
index 6ca90bcf..7828eccb 100644
--- a/recipes-demo/webapp-samples/html5-aquarium_git.bb
+++ b/recipes-demo/webapp-samples/html5-aquarium_git.bb
@@ -1,10 +1,16 @@
SUMMARY = "AGL HTML5 Aquarium Demo"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://aquarium/LICENSE;md5=9f0d95e61aa217eacd61ee6833cf411c"
-DESKTOP_FILE = "webapps-aquarium.desktop"
+APPINFO_FILE = "appinfo-aquarium.json"
require webapp-samples.inc
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-aquarium"
+AGL_APP_NAME = "Aquarium"
+
do_install:append() {
cp -R --no-dereference --preserve=mode,links ${S}/aquarium/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
}