summaryrefslogtreecommitdiffstats
path: root/recipes-demo/webapp-samples/html5-jitsi_git.bb
diff options
context:
space:
mode:
authorRoger Zanoni <rzanoni@igalia.com>2022-11-09 14:31:36 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-11-14 11:31:15 +0000
commit7f3038e5efb5fed78457a5855560a3ae8912f783 (patch)
tree109b04c8af5b2f0ca282f71c825a7bf41e7cd0ff /recipes-demo/webapp-samples/html5-jitsi_git.bb
parentb757b6bb346ccc673f3b3377c46ba0bd54decd32 (diff)
Restore webapp samples
The desktop files aren't used anymore, change the recipes to use appinfo.json instead. Bug-AGL: SPEC-4605 Signed-off-by: Roger Zanoni <rzanoni@igalia.com> Change-Id: Ie03aef155217f59bb6363f18b2781adbacc93786
Diffstat (limited to 'recipes-demo/webapp-samples/html5-jitsi_git.bb')
-rw-r--r--recipes-demo/webapp-samples/html5-jitsi_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-demo/webapp-samples/html5-jitsi_git.bb b/recipes-demo/webapp-samples/html5-jitsi_git.bb
index 4c92e46b..e24ff32a 100644
--- a/recipes-demo/webapp-samples/html5-jitsi_git.bb
+++ b/recipes-demo/webapp-samples/html5-jitsi_git.bb
@@ -1,10 +1,16 @@
SUMMARY = "AGL HTML5 Jitsi"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
-DESKTOP_FILE = "webapps-jitsi.desktop"
+APPINFO_FILE = "appinfo-jitsi.json"
require webapp-samples.inc
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-jitsi"
+AGL_APP_NAME = "Jitsi"
+
do_install:append() {
cp -R --no-dereference --preserve=mode,links ${S}/jitsi/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
}