summaryrefslogtreecommitdiffstats
path: root/recipes-demo/webapp-samples
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 12:46:02 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-07-01 08:58:18 +0000
commit63e0ea358f1902b1dd9968b21b5eea649d04329e (patch)
tree4231493c300f4d9ea2c84b6e290919486bf7e0b6 /recipes-demo/webapp-samples
parent9eda76e3a9c869030ff4bcf66704207753666a6c (diff)
Move html5 demo into sublayer
The HTML5 demo needs additional fixes. Move it into a sublayer and activate with agl-demo-html5. Bug-AGL: SPEC-5188 Change-Id: I2f1a07dcfbcaf7e09d4d0d3aec1aa8f096336287 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30042 ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account Reviewed-by: Scott Murray <scott.murray@konsulko.com> ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'recipes-demo/webapp-samples')
-rw-r--r--recipes-demo/webapp-samples/files/appinfo-aquarium.json11
-rw-r--r--recipes-demo/webapp-samples/files/appinfo-examples.json11
-rw-r--r--recipes-demo/webapp-samples/files/appinfo-jitsi.json11
-rw-r--r--recipes-demo/webapp-samples/files/appinfo-youtube.json11
-rw-r--r--recipes-demo/webapp-samples/html5-aquarium_git.bb17
-rw-r--r--recipes-demo/webapp-samples/html5-examples_git.bb17
-rw-r--r--recipes-demo/webapp-samples/html5-jitsi_git.bb17
-rw-r--r--recipes-demo/webapp-samples/html5-youtube_git.bb17
-rw-r--r--recipes-demo/webapp-samples/webapp-samples.inc23
9 files changed, 0 insertions, 135 deletions
diff --git a/recipes-demo/webapp-samples/files/appinfo-aquarium.json b/recipes-demo/webapp-samples/files/appinfo-aquarium.json
deleted file mode 100644
index 76fdd9e34..000000000
--- a/recipes-demo/webapp-samples/files/appinfo-aquarium.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "id": "webapps-aquarium",
- "title": "Aquarium",
- "description": "HTML5 WebGL Aquarium sample",
- "version": "0.0.0",
- "vendor": "Igalia, S.L.",
- "type": "web",
- "main": "aquarium.html",
- "uiRevision": "2",
- "icon": "icon.svg"
-}
diff --git a/recipes-demo/webapp-samples/files/appinfo-examples.json b/recipes-demo/webapp-samples/files/appinfo-examples.json
deleted file mode 100644
index c1c960dba..000000000
--- a/recipes-demo/webapp-samples/files/appinfo-examples.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "id": "webapps-examples",
- "title": "Examples",
- "description": "HTML5 examples",
- "version": "0.0.0",
- "vendor": "Igalia, S.L.",
- "type": "web",
- "main": "index.html",
- "uiRevision": "2",
- "icon": "icon.svg"
-}
diff --git a/recipes-demo/webapp-samples/files/appinfo-jitsi.json b/recipes-demo/webapp-samples/files/appinfo-jitsi.json
deleted file mode 100644
index f5e1d8082..000000000
--- a/recipes-demo/webapp-samples/files/appinfo-jitsi.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "id": "webapps-jitsi",
- "title": "Jitsi",
- "description": "HTML5 Jitsi sample",
- "version": "0.0.0",
- "vendor": "Igalia, S.L.",
- "type": "web",
- "main": "index.html",
- "uiRevision": "2",
- "icon": "icon.svg"
-}
diff --git a/recipes-demo/webapp-samples/files/appinfo-youtube.json b/recipes-demo/webapp-samples/files/appinfo-youtube.json
deleted file mode 100644
index f844bf7ac..000000000
--- a/recipes-demo/webapp-samples/files/appinfo-youtube.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "id": "webapps-youtube",
- "title": "Youtube",
- "description": "HTML5 Youtube sample",
- "version": "0.0.0",
- "vendor": "Igalia, S.L.",
- "type": "web",
- "main": "index.html",
- "uiRevision": "2",
- "icon": "icon.svg"
-}
diff --git a/recipes-demo/webapp-samples/html5-aquarium_git.bb b/recipes-demo/webapp-samples/html5-aquarium_git.bb
deleted file mode 100644
index 0afc8514a..000000000
--- a/recipes-demo/webapp-samples/html5-aquarium_git.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "AGL HTML5 Aquarium Demo"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://aquarium/LICENSE;md5=9f0d95e61aa217eacd61ee6833cf411c"
-APPINFO_FILE = "appinfo-aquarium.json"
-
-require webapp-samples.inc
-
-inherit agl-app
-
-AGL_APP_TEMPLATE = "agl-app-web"
-AGL_APP_ID = "webapps-aquarium"
-AGL_APP_NAME = "Aquarium"
-
-do_install:append() {
- cp -R --no-dereference --preserve=mode,links ${S}/aquarium/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
-}
-
diff --git a/recipes-demo/webapp-samples/html5-examples_git.bb b/recipes-demo/webapp-samples/html5-examples_git.bb
deleted file mode 100644
index c2b131aff..000000000
--- a/recipes-demo/webapp-samples/html5-examples_git.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "AGL HTML5 Examples"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
-APPINFO_FILE = "appinfo-examples.json"
-
-require webapp-samples.inc
-
-inherit agl-app
-
-AGL_APP_TEMPLATE = "agl-app-web"
-AGL_APP_ID = "webapps-examples"
-AGL_APP_NAME = "Examples"
-
-do_install:append() {
- cp -R --no-dereference --preserve=mode,links ${S}/examples/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
-}
-
diff --git a/recipes-demo/webapp-samples/html5-jitsi_git.bb b/recipes-demo/webapp-samples/html5-jitsi_git.bb
deleted file mode 100644
index e382cb030..000000000
--- a/recipes-demo/webapp-samples/html5-jitsi_git.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "AGL HTML5 Jitsi"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
-APPINFO_FILE = "appinfo-jitsi.json"
-
-require webapp-samples.inc
-
-inherit agl-app
-
-AGL_APP_TEMPLATE = "agl-app-web"
-AGL_APP_ID = "webapps-jitsi"
-AGL_APP_NAME = "Jitsi"
-
-do_install:append() {
- cp -R --no-dereference --preserve=mode,links ${S}/jitsi/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
-}
-
diff --git a/recipes-demo/webapp-samples/html5-youtube_git.bb b/recipes-demo/webapp-samples/html5-youtube_git.bb
deleted file mode 100644
index 44a964406..000000000
--- a/recipes-demo/webapp-samples/html5-youtube_git.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "AGL HTML5 Youtube"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
-APPINFO_FILE = "appinfo-youtube.json"
-
-require webapp-samples.inc
-
-inherit agl-app
-
-AGL_APP_TEMPLATE = "agl-app-web"
-AGL_APP_ID = "webapps-youtube"
-AGL_APP_NAME = "Youtube"
-
-do_install:append() {
- cp -R --no-dereference --preserve=mode,links ${S}/youtube/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
-}
-
diff --git a/recipes-demo/webapp-samples/webapp-samples.inc b/recipes-demo/webapp-samples/webapp-samples.inc
deleted file mode 100644
index 1a74a46c0..000000000
--- a/recipes-demo/webapp-samples/webapp-samples.inc
+++ /dev/null
@@ -1,23 +0,0 @@
-HOMEPAGE = "https://github.com/AGL-web-applications/webapp-samples"
-SECTION = "apps"
-
-PV = "1.0+git${SRCPV}"
-S = "${WORKDIR}/git"
-B = "${WORKDIR}/build"
-
-SRC_URI = " \
- git://github.com/AGL-web-applications/webapp-samples.git;protocol=https;branch=master \
- file://${APPINFO_FILE} \
-"
-SRCREV = "b24a62cc524bdec98a61acc03fc53cbab24c1571"
-
-WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
-
-do_install() {
- install -d ${D}${WAM_APPLICATIONS_DIR}/${PN}
- install ${WORKDIR}/${APPINFO_FILE} ${D}${WAM_APPLICATIONS_DIR}/${PN}/appinfo.json
-}
-
-FILES:${PN} = " \
- ${WAM_APPLICATIONS_DIR}/${PN} \
-"