summaryrefslogtreecommitdiffstats
path: root/recipes-demo/window-management-client-grpc
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-11-22 17:58:54 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-25 11:25:41 +0000
commit24e55fccab51e217d4452968b082f0531a05fcb5 (patch)
treee3e0dd1e9dfed15c9f94ec0af20f2b6590b86845 /recipes-demo/window-management-client-grpc
parent275de1d5dceae84c872e354f2f8b15ad275f97ae (diff)
Update Qt demo app SRCREVs
Update Qt demo app SRCREVs to pick up their Qt6 updates, and drop the now unnecssary Qt6 patches. Also, the MapBox configuration support has been removed from the ondemandnavi-config recipe, as that backend is no longer supported by QtLocation in Qt6. Bug-AGL: SPEC-5294 Change-Id: Ib44c6be83c3d4654c9ed5adffa3e9d34057eb2ae Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30543 ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account
Diffstat (limited to 'recipes-demo/window-management-client-grpc')
-rw-r--r--recipes-demo/window-management-client-grpc/window-management-client-grpc/0001-Migrate-to-Qt-6.patch74
-rw-r--r--recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb6
2 files changed, 2 insertions, 78 deletions
diff --git a/recipes-demo/window-management-client-grpc/window-management-client-grpc/0001-Migrate-to-Qt-6.patch b/recipes-demo/window-management-client-grpc/window-management-client-grpc/0001-Migrate-to-Qt-6.patch
deleted file mode 100644
index 3562b64f6..000000000
--- a/recipes-demo/window-management-client-grpc/window-management-client-grpc/0001-Migrate-to-Qt-6.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 75a141871c45b7e940fbdc9f0c97c43734789074 Mon Sep 17 00:00:00 2001
-From: Indivara Weerasuriya <1806262-indivara@users.noreply.git.qt.io>
-Date: Wed, 24 Jul 2024 09:57:30 +0900
-Subject: [PATCH] Migrate to Qt 6
-
----
- meson.build | 2 +-
- src/meson.build | 10 +++++-----
- src/qml/Main.qml | 2 +-
- 3 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index beb933d..634714f 100644
---- a/meson.build
-+++ b/meson.build
-@@ -26,5 +26,5 @@ project (
- license: 'MIT/Expat',
- )
-
--qt5 = import('qt5')
-+qt = import('qt6')
- subdir('src')
-diff --git a/src/meson.build b/src/meson.build
-index b37e24f..5a59f13 100644
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -1,7 +1,7 @@
- pkgconfig = import('pkgconfig')
- cpp = meson.get_compiler('cpp')
-
--qt5_dep = dependency('qt5', modules: ['Qml', 'Quick', 'Gui'])
-+qt_dep = dependency('qt6', modules: ['Qml', 'Quick', 'Gui'])
-
- grpcpp_reflection_dep = cpp.find_library('grpc++_reflection')
- protoc = find_program('protoc')
-@@ -31,7 +31,7 @@ grpc_deps = [
- ]
-
- window_mgnt_dep = [
-- qt5_dep,
-+ qt_dep,
- grpc_deps,
- ]
-
-@@ -40,14 +40,14 @@ window_mgnt_resources = [
- 'qml/qml.qrc'
- ]
-
--resource_files = qt5.compile_resources(sources: window_mgnt_resources)
-+resource_files = qt.compile_resources(sources: window_mgnt_resources)
-
- window_mgnt_src_headers = [
- 'AglShellGrpcClient.h',
- ]
-
--moc_files = qt5.compile_moc(headers: window_mgnt_src_headers,
-- dependencies: qt5_dep)
-+moc_files = qt.compile_moc(headers: window_mgnt_src_headers,
-+ dependencies: qt_dep)
- window_mgnt_src = [
- 'AglShellGrpcClient.cpp',
- 'main.cpp',
-diff --git a/src/qml/Main.qml b/src/qml/Main.qml
-index 151f3b8..5ddd2f7 100644
---- a/src/qml/Main.qml
-+++ b/src/qml/Main.qml
-@@ -10,6 +10,6 @@ Window {
-
- Image {
- anchors.fill: parent
-- source: './images/AGL_HMI_Blue_Background_NoCar-01.png'
-+ source: 'qrc:/images/AGL_HMI_Blue_Background_NoCar-01.png'
- }
- }
diff --git a/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb b/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb
index c864be897..d963f481e 100644
--- a/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb
+++ b/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb
@@ -12,10 +12,8 @@ DEPENDS = "qtbase qtdeclarative qtwayland \
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/window-management-client-grpc.git;protocol=https;branch=${AGL_BRANCH} \
- file://0001-Migrate-to-Qt-6.patch \
- "
-SRCREV = "cb7aa009ef9873967152e716fb01fecc30d401f7"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/window-management-client-grpc.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "ddb80d78079653871100e64ebd7fbe112a22bf4c"
S = "${WORKDIR}/git"