summaryrefslogtreecommitdiffstats
path: root/recipes-demo/window-management-client-grpc
diff options
context:
space:
mode:
authorIndivara Weerasuriya <indivara.weerasuriya@qt.io>2024-07-30 19:47:24 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-20 13:35:26 +0000
commit59ae0b13d2bb14fbf12117f2f55bfcb6f06f104b (patch)
treeba38354db9033675bde1ad07700d796160450f8f /recipes-demo/window-management-client-grpc
parenta37e8ed0c8f997e13d719c7e5d956b5febc9cfa5 (diff)
Migrate demo app recipes and patch apps to Qt 6
Bug-AGL: SPEC-5294 Change-Id: I6b9ff940745f88af9a3b69e29917082e52b25f88 Signed-off-by: Indivara Weerasuriya <indivara.weerasuriya@qt.io> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30141 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-demo/window-management-client-grpc')
-rw-r--r--recipes-demo/window-management-client-grpc/window-management-client-grpc/0001-Migrate-to-Qt-6.patch74
-rw-r--r--recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb6
2 files changed, 78 insertions, 2 deletions
diff --git a/recipes-demo/window-management-client-grpc/window-management-client-grpc/0001-Migrate-to-Qt-6.patch b/recipes-demo/window-management-client-grpc/window-management-client-grpc/0001-Migrate-to-Qt-6.patch
new file mode 100644
index 000000000..3562b64f6
--- /dev/null
+++ b/recipes-demo/window-management-client-grpc/window-management-client-grpc/0001-Migrate-to-Qt-6.patch
@@ -0,0 +1,74 @@
+From 75a141871c45b7e940fbdc9f0c97c43734789074 Mon Sep 17 00:00:00 2001
+From: Indivara Weerasuriya <1806262-indivara@users.noreply.git.qt.io>
+Date: Wed, 24 Jul 2024 09:57:30 +0900
+Subject: [PATCH] Migrate to Qt 6
+
+---
+ meson.build | 2 +-
+ src/meson.build | 10 +++++-----
+ src/qml/Main.qml | 2 +-
+ 3 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index beb933d..634714f 100644
+--- a/meson.build
++++ b/meson.build
+@@ -26,5 +26,5 @@ project (
+ license: 'MIT/Expat',
+ )
+
+-qt5 = import('qt5')
++qt = import('qt6')
+ subdir('src')
+diff --git a/src/meson.build b/src/meson.build
+index b37e24f..5a59f13 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -1,7 +1,7 @@
+ pkgconfig = import('pkgconfig')
+ cpp = meson.get_compiler('cpp')
+
+-qt5_dep = dependency('qt5', modules: ['Qml', 'Quick', 'Gui'])
++qt_dep = dependency('qt6', modules: ['Qml', 'Quick', 'Gui'])
+
+ grpcpp_reflection_dep = cpp.find_library('grpc++_reflection')
+ protoc = find_program('protoc')
+@@ -31,7 +31,7 @@ grpc_deps = [
+ ]
+
+ window_mgnt_dep = [
+- qt5_dep,
++ qt_dep,
+ grpc_deps,
+ ]
+
+@@ -40,14 +40,14 @@ window_mgnt_resources = [
+ 'qml/qml.qrc'
+ ]
+
+-resource_files = qt5.compile_resources(sources: window_mgnt_resources)
++resource_files = qt.compile_resources(sources: window_mgnt_resources)
+
+ window_mgnt_src_headers = [
+ 'AglShellGrpcClient.h',
+ ]
+
+-moc_files = qt5.compile_moc(headers: window_mgnt_src_headers,
+- dependencies: qt5_dep)
++moc_files = qt.compile_moc(headers: window_mgnt_src_headers,
++ dependencies: qt_dep)
+ window_mgnt_src = [
+ 'AglShellGrpcClient.cpp',
+ 'main.cpp',
+diff --git a/src/qml/Main.qml b/src/qml/Main.qml
+index 151f3b8..5ddd2f7 100644
+--- a/src/qml/Main.qml
++++ b/src/qml/Main.qml
+@@ -10,6 +10,6 @@ Window {
+
+ Image {
+ anchors.fill: parent
+- source: './images/AGL_HMI_Blue_Background_NoCar-01.png'
++ source: 'qrc:/images/AGL_HMI_Blue_Background_NoCar-01.png'
+ }
+ }
diff --git a/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb b/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb
index 769a56f61..c864be897 100644
--- a/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb
+++ b/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb
@@ -6,13 +6,15 @@ SECTION = "apps"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-DEPENDS = "qtbase qtdeclarative qtquickcontrols2 qtwayland \
+DEPENDS = "qtbase qtdeclarative qtwayland \
qtwayland-native libqtappfw grpc grpc-native \
"
PV = "2.0+git${SRCPV}"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/window-management-client-grpc.git;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/window-management-client-grpc.git;protocol=https;branch=${AGL_BRANCH} \
+ file://0001-Migrate-to-Qt-6.patch \
+ "
SRCREV = "cb7aa009ef9873967152e716fb01fecc30d401f7"
S = "${WORKDIR}/git"