summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-16 18:24:25 -0400
committerScott Murray <scott.murray@konsulko.com>2024-05-27 21:28:34 +0000
commitb26515dcf2afc510cc59782f99965f10b96be433 (patch)
tree60cb8103f410306171ae487bd4784b0363403297 /recipes-demo
parent2e0fd28b2470f6d81bfb1b0b273af5742060ed6a (diff)
Add gateway demo
Changes: - Add recipe for AGL VSS to MQTT proxy daemon - Update agl-vcar.dbc CAN database definition to add signals useful for demoing the proxy (per V2C EG discussion). - Add a patch to kuksa-dbc-feeder to allow sensor signal updates to generate CAN messages in output mode. - Add VSS vspec variants to define the desired CAN input and output support for the various kuksa-dbc-feeder instances in the default and full gateway demos. - Add configurations for kuksa-dbc-feeder for the running the default gateway demo with CAN output from a demo control panel instance on a single CAN interface, as well as a fuller setup with a second kuksa-dbc-feeder running against a second CAN interface on the gateway to handle the demo steering wheel and HVAC support. - Add gateway demo specific configuration files for various KUKSA.val databroker clients to override the databroker location. - Add agl-gateway-demo and agl-gateway-demo-preconfigured images for the default and full demos. - Add *-preconfigured-gateway image flavors for the Flutter IVI, IC, and KVM demo images that support running with the databroker on the gateway. NOTES: - The *-preconfigured-gateway images assume the gateway has an IP address of 192.168.10.4. - Required changes to the agl-demo-control-panel application and the addition of a agl-ivi-demo-control-panel-preconfigured-gateway image will come in a subsequent change. Bug-AGL: SPEC-5107, SPEC-5138 Change-Id: I9797aa72737af7af3d791a5151198f80b6d90e0d Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29921 ci-image-boot-test: Jenkins Job builder account ci-image-build: Jenkins Job builder account Tested-by: Jenkins Job builder account
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf.default (renamed from recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf)0
-rw-r--r--recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf.gateway-demo4
-rw-r--r--recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb27
-rw-r--r--recipes-demo/agl-service-hvac/agl-service-hvac/agl-service-hvac.conf.default (renamed from recipes-demo/agl-service-hvac/agl-service-hvac/agl-service-hvac.conf)0
-rw-r--r--recipes-demo/agl-service-hvac/agl-service-hvac/agl-service-hvac.conf.gateway-demo4
-rw-r--r--recipes-demo/agl-service-hvac/agl-service-hvac_git.bb28
-rw-r--r--recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.gateway-demo4
-rw-r--r--recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb33
-rw-r--r--recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml.gateway-demo6
-rw-r--r--recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml.kvm-gateway-demo10
-rw-r--r--recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb39
-rw-r--r--recipes-demo/navigation/ondemandnavi/navigation.conf.gateway-demo4
-rw-r--r--recipes-demo/navigation/ondemandnavi_git.bb14
-rw-r--r--recipes-demo/navigation/tbtnavi/tbtnavi.conf.gateway-demo4
-rw-r--r--recipes-demo/navigation/tbtnavi_git.bb24
15 files changed, 163 insertions, 38 deletions
diff --git a/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf.default
index e0d84f8f..e0d84f8f 100644
--- a/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf
+++ b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf.default
diff --git a/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf.gateway-demo b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf.gateway-demo
new file mode 100644
index 00000000..c6095ac3
--- /dev/null
+++ b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer/agl-service-audiomixer.conf.gateway-demo
@@ -0,0 +1,4 @@
+[kuksa-client]
+hostname = "192.168.10.4"
+tls-server-name = "localhost"
+authorization = "/etc/xdg/AGL/agl-service-audiomixer/agl-service-audiomixer.token"
diff --git a/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
index e6b7d64b..a1f6f795 100644
--- a/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
+++ b/recipes-demo/agl-service-audiomixer/agl-service-audiomixer_git.bb
@@ -20,7 +20,8 @@ DEPENDS = " \
"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-audiomixer.git;protocol=https;branch=${AGL_BRANCH} \
- file://agl-service-audiomixer.conf \
+ file://agl-service-audiomixer.conf.default \
+ file://agl-service-audiomixer.conf.gateway-demo \
file://agl-service-audiomixer.token \
"
SRCREV = "0ff3ef1b254364639fc42495bbcfb4760250990a"
@@ -28,7 +29,7 @@ SRCREV = "0ff3ef1b254364639fc42495bbcfb4760250990a"
PV = "2.0+git${SRCPV}"
S = "${WORKDIR}/git"
-inherit meson pkgconfig systemd
+inherit meson pkgconfig systemd update-alternatives
EXTRA_OEMESON += "-Dprotos=${STAGING_INCDIR}"
@@ -43,10 +44,28 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer
- install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf.default ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/agl-service-audiomixer.token ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer/
}
FILES:${PN} += "${systemd_system_unitdir}"
-RDEPENDS:${PN} += "kuksa-databroker"
+RDEPENDS:${PN} += "${PN}-conf"
+
+ALTERNATIVE_LINK_NAME[agl-service-audiomixer.conf] = "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf"
+
+PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-gateway-demo"
+
+FILES:${PN}-conf += "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.default"
+RDEPENDS:${PN}-conf = "${PN}"
+RPROVIDES:${PN}-conf = "agl-service-audiomixer.conf"
+ALTERNATIVE:${PN}-conf = "agl-service-audiomixer.conf"
+ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.default"
+
+FILES:${PN}-conf-gateway-demo += "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.gateway-demo"
+RDEPENDS:${PN}-conf-gateway-demo = "${PN}"
+RPROVIDES:${PN}-conf-gateway-demo = "agl-service-audiomixer.conf"
+ALTERNATIVE:${PN}-conf-gateway-demo = "agl-service-audiomixer.conf"
+ALTERNATIVE_TARGET_${PN}-conf-gateway-demo = "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.gateway-demo"
+ALTERNATIVE_PRIORITY_${PN}-conf-gateway-demo = "20"
diff --git a/recipes-demo/agl-service-hvac/agl-service-hvac/agl-service-hvac.conf b/recipes-demo/agl-service-hvac/agl-service-hvac/agl-service-hvac.conf.default
index ca2f4f69..ca2f4f69 100644
--- a/recipes-demo/agl-service-hvac/agl-service-hvac/agl-service-hvac.conf
+++ b/recipes-demo/agl-service-hvac/agl-service-hvac/agl-service-hvac.conf.default
diff --git a/recipes-demo/agl-service-hvac/agl-service-hvac/agl-service-hvac.conf.gateway-demo b/recipes-demo/agl-service-hvac/agl-service-hvac/agl-service-hvac.conf.gateway-demo
new file mode 100644
index 00000000..929bbc1b
--- /dev/null
+++ b/recipes-demo/agl-service-hvac/agl-service-hvac/agl-service-hvac.conf.gateway-demo
@@ -0,0 +1,4 @@
+[kuksa-client]
+hostname = "192.168.10.4"
+tls-server-name = "localhost"
+authorization = "/etc/xdg/AGL/agl-service-hvac/agl-service-hvac.token"
diff --git a/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb b/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb
index 73d35f55..721cdd7d 100644
--- a/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb
+++ b/recipes-demo/agl-service-hvac/agl-service-hvac_git.bb
@@ -18,7 +18,8 @@ DEPENDS = " \
"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-hvac;protocol=https;branch=${AGL_BRANCH} \
- file://agl-service-hvac.conf \
+ file://agl-service-hvac.conf.default \
+ file://agl-service-hvac.conf.gateway-demo \
file://agl-service-hvac.token \
"
SRCREV = "1f55937667e35fb79dabee0e180787e34a59169a"
@@ -26,7 +27,7 @@ SRCREV = "1f55937667e35fb79dabee0e180787e34a59169a"
PV = "2.0+git${SRCPV}"
S = "${WORKDIR}/git"
-inherit meson pkgconfig systemd
+inherit meson pkgconfig systemd update-alternatives
EXTRA_OEMESON += "-Dprotos=${STAGING_INCDIR}"
@@ -41,10 +42,29 @@ do_install:append() {
# until a packaging/sandboxing/MAC scheme is (re)implemented or
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/agl-service-hvac
- install -m 0644 ${WORKDIR}/agl-service-hvac.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/agl-service-hvac.conf.default ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/agl-service-hvac.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/agl-service-hvac.token ${D}${sysconfdir}/xdg/AGL/agl-service-hvac/
}
FILES:${PN} += "${systemd_system_unitdir}"
-RDEPENDS:${PN} += "kuksa-databroker kuksa-databroker-agl"
+RDEPENDS:${PN} += "${PN}-conf"
+
+ALTERNATIVE_LINK_NAME[agl-service-hvac.conf] = "${sysconfdir}/xdg/AGL/agl-service-hvac.conf"
+
+PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-gateway-demo"
+
+FILES:${PN}-conf += "${sysconfdir}/xdg/AGL/agl-service-hvac.conf.default"
+RDEPENDS:${PN}-conf = "${PN}"
+RPROVIDES:${PN}-conf = "agl-service-hvac.conf"
+ALTERNATIVE:${PN}-conf = "agl-service-hvac.conf"
+ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/agl-service-hvac.conf.default"
+
+FILES:${PN}-conf-gateway-demo += "${sysconfdir}/xdg/AGL/agl-service-hvac.conf.gateway-demo"
+RDEPENDS:${PN}-conf-gateway-demo = "${PN}"
+RPROVIDES:${PN}-conf-gateway-demo = "agl-service-hvac.conf"
+ALTERNATIVE:${PN}-conf-gateway-demo = "agl-service-hvac.conf"
+ALTERNATIVE_TARGET_${PN}-conf-gateway-demo = "${sysconfdir}/xdg/AGL/agl-service-hvac.conf.gateway-demo"
+ALTERNATIVE_PRIORITY_${PN}-conf-gateway-demo = "20"
+
diff --git a/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.gateway-demo b/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.gateway-demo
new file mode 100644
index 00000000..662a350f
--- /dev/null
+++ b/recipes-demo/flutter-cluster-dashboard/files/cluster-dashboard.yaml.gateway-demo
@@ -0,0 +1,4 @@
+hostname: 192.168.10.4
+authorization : "/etc/xdg/AGL/cluster-dashboard/cluster-dashboard.token"
+use-tls : true
+tls-server-name : "localhost"
diff --git a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
index f81d8e73..f3dd8f1e 100644
--- a/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
+++ b/recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb
@@ -13,6 +13,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-instrument-clust
file://flutter_cluster_dashboard_on_bg.json \
file://cluster-dashboard.yaml \
file://cluster-dashboard.yaml.demo \
+ file://cluster-dashboard.yaml.gateway-demo \
file://cluster-dashboard.yaml.kvm-demo \
file://cluster-dashboard.token \
file://kvm.conf \
@@ -41,6 +42,7 @@ do_install:append() {
install -d ${D}${sysconfdir}/xdg/AGL/cluster-dashboard
install -m 0644 ${WORKDIR}/cluster-dashboard.yaml ${D}${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default
install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.gateway-demo ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/cluster-dashboard.yaml.kvm-demo ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/cluster-dashboard.token ${D}${sysconfdir}/xdg/AGL/cluster-dashboard/
}
@@ -51,30 +53,35 @@ FILES:${PN} += "${datadir} ${sysconfdir}/xdg/AGL"
RDEPENDS:${PN} += "flutter-auto agl-flutter-env liberation-fonts"
-PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-demo ${PN}-conf-kvm-demo"
-
+PACKAGE_BEFORE_PN += "${PN}-conf"
FILES:${PN}-conf += "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default"
RDEPENDS:${PN}-conf = "${PN}"
RPROVIDES:${PN}-conf = "cluster-dashboard.yaml"
-RCONFLICTS:${PN}-conf = "${PN}-conf-demo"
ALTERNATIVE:${PN}-conf = "cluster-dashboard.yaml"
ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.default"
-FILES:${PN}-conf-demo += " \
- ${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.demo \
-"
+PACKAGE_BEFORE_PN += "${PN}-conf-demo"
+FILES:${PN}-conf-demo += "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.demo"
RDEPENDS:${PN}-conf-demo = "${PN}"
RPROVIDES:${PN}-conf-demo = "cluster-dashboard.yaml"
-RCONFLICTS:${PN}-conf-demo = "${PN}-conf"
ALTERNATIVE:${PN}-conf-demo = "cluster-dashboard.yaml"
ALTERNATIVE_TARGET_${PN}-conf-demo = "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.demo"
-FILES:${PN}-conf-kvm-demo += " \
- ${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.kvm-demo \
- ${systemd_system_unitdir}/flutter-cluster-dashboard.service.d/kvm.conf \
-"
-RDEPENDS:${PN}-conf-kvm-demo = "${PN}"
+PACKAGE_BEFORE_PN += "${PN}-conf-gateway-demo"
+FILES:${PN}-conf-gateway-demo += "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.gateway-demo"
+RDEPENDS:${PN}-conf-gateway-demo = "${PN}"
+RPROVIDES:${PN}-conf-gateway-demo = "cluster-dashboard.yaml"
+ALTERNATIVE:${PN}-conf-gateway-demo = "cluster-dashboard.yaml"
+ALTERNATIVE_TARGET_${PN}-conf-gateway-demo = "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.gateway-demo"
+
+# systemd override to add network-online.target dependency for KVM setups
+PACKAGE_BEFORE_PN += "${PN}-conf-kvm"
+FILES:${PN}-conf-kvm += "${systemd_system_unitdir}/flutter-cluster-dashboard.service.d/kvm.conf"
+RDEPENDS:${PN}-conf-kvm = "${PN}"
+
+PACKAGE_BEFORE_PN += "${PN}-conf-kvm-demo"
+FILES:${PN}-conf-kvm-demo += "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.kvm-demo"
+RDEPENDS:${PN}-conf-kvm-demo = "${PN} ${PN}-conf-kvm"
RPROVIDES:${PN}-conf-kvm-demo = "cluster-dashboard.yaml"
-RCONFLICTS:${PN}-conf-kvm-demo = "${PN}-conf"
ALTERNATIVE:${PN}-conf-kvm-demo = "cluster-dashboard.yaml"
ALTERNATIVE_TARGET_${PN}-conf-kvm-demo = "${sysconfdir}/xdg/AGL/cluster-dashboard.yaml.kvm-demo"
diff --git a/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml.gateway-demo b/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml.gateway-demo
new file mode 100644
index 00000000..e9346bc4
--- /dev/null
+++ b/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml.gateway-demo
@@ -0,0 +1,6 @@
+kuksa:
+ hostname : 192.168.10.4
+ port : 55555
+ authorization : "/etc/xdg/AGL/ics-homescreen/ics-homescreen.token"
+ use-tls : true
+ tls-server-name : localhost
diff --git a/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml.kvm-gateway-demo b/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml.kvm-gateway-demo
new file mode 100644
index 00000000..5d6e73b3
--- /dev/null
+++ b/recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml.kvm-gateway-demo
@@ -0,0 +1,10 @@
+kuksa:
+ hostname : 192.168.10.4
+ port : 55555
+ authorization : "/etc/xdg/AGL/ics-homescreen/ics-homescreen.token"
+ use-tls : true
+ tls-server-name : localhost
+radio:
+ hostname : 172.16.10.1
+mpd:
+ hostname : 172.16.10.1
diff --git a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
index 17e55994..45d75b7c 100644
--- a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
+++ b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
@@ -10,7 +10,9 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;p
file://flutter-ics-homescreen.json \
file://flutter-ics-homescreen.service \
file://ics-homescreen.yaml \
+ file://ics-homescreen.yaml.gateway-demo \
file://ics-homescreen.yaml.kvm-demo \
+ file://ics-homescreen.yaml.kvm-gateway-demo \
file://ics-homescreen.token \
file://radio-presets.yaml \
file://kvm.conf \
@@ -46,7 +48,9 @@ do_install:append() {
# something like OAuth is plumbed in as an alternative.
install -d ${D}${sysconfdir}/xdg/AGL/ics-homescreen
install -m 0644 ${WORKDIR}/ics-homescreen.yaml ${D}${sysconfdir}/xdg/AGL/ics-homescreen.yaml.default
+ install -m 0644 ${WORKDIR}/ics-homescreen.yaml.gateway-demo ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/ics-homescreen.yaml.kvm-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/ics-homescreen.yaml.kvm-gateway-demo ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/ics-homescreen.token ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
install -m 0644 ${WORKDIR}/radio-presets.yaml ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
}
@@ -61,21 +65,38 @@ RDEPENDS:${PN} += " \
applaunchd \
"
-PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-kvm-demo"
-
+PACKAGE_BEFORE_PN += "${PN}-conf"
FILES:${PN}-conf += "${sysconfdir}/xdg/AGL/ics-homescreen.yaml.default"
RDEPENDS:${PN}-conf = "${PN}"
RPROVIDES:${PN}-conf = "ics-homescreen.yaml"
-RCONFLICTS:${PN}-conf = "${PN}-conf-kvm-demo"
ALTERNATIVE:${PN}-conf = "ics-homescreen.yaml"
ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/ics-homescreen.yaml.default"
-FILES:${PN}-conf-kvm-demo += " \
- ${sysconfdir}/xdg/AGL/ics-homescreen.yaml.kvm-demo \
- ${systemd_system_unitdir}/flutter-ics-homescreen.service.d/kvm.conf \
-"
-RDEPENDS:${PN}-conf-kvm-demo = "${PN}"
+PACKAGE_BEFORE_PN += "${PN}-conf-gateway-demo"
+FILES:${PN}-conf-gateway-demo += "${sysconfdir}/xdg/AGL/ics-homescreen.yaml.gateway-demo"
+RDEPENDS:${PN}-conf-gateway-demo = "${PN}"
+RPROVIDES:${PN}-conf-gateway-demo = "ics-homescreen.yaml"
+ALTERNATIVE:${PN}-conf-gateway-demo = "ics-homescreen.yaml"
+ALTERNATIVE_TARGET_${PN}-conf-gateway-demo = "${sysconfdir}/xdg/AGL/ics-homescreen.yaml.gateway-demo"
+ALTERNATIVE_PRIORITY_${PN}-conf-gateway-demo = "20"
+
+# systemd override to add network-online.target dependency for KVM setups
+PACKAGE_BEFORE_PN += "${PN}-conf-kvm"
+FILES:${PN}-conf-kvm += "${systemd_system_unitdir}/flutter-ics-homescreen.service.d/kvm.conf"
+RDEPENDS:${PN}-conf-kvm = "${PN}"
+
+PACKAGE_BEFORE_PN += "${PN}-conf-kvm-demo"
+FILES:${PN}-conf-kvm-demo += "${sysconfdir}/xdg/AGL/ics-homescreen.yaml.kvm-demo"
+RDEPENDS:${PN}-conf-kvm-demo = "${PN} ${PN}-conf-kvm"
RPROVIDES:${PN}-conf-kvm-demo = "ics-homescreen.yaml"
-RCONFLICTS:${PN}-conf-kvm-demo = "${PN}-conf"
ALTERNATIVE:${PN}-conf-kvm-demo = "ics-homescreen.yaml"
ALTERNATIVE_TARGET_${PN}-conf-kvm-demo = "${sysconfdir}/xdg/AGL/ics-homescreen.yaml.kvm-demo"
+ALTERNATIVE_PRIORITY_${PN}-conf-kvm-demo = "30"
+
+PACKAGE_BEFORE_PN += "${PN}-conf-kvm-gateway-demo"
+FILES:${PN}-conf-kvm-gateway-demo += "${sysconfdir}/xdg/AGL/ics-homescreen.yaml.kvm-gateway-demo"
+RDEPENDS:${PN}-conf-kvm-gateway-demo = "${PN} ${PN}-conf-kvm"
+RPROVIDES:${PN}-conf-kvm-gateway-demo = "ics-homescreen.yaml"
+ALTERNATIVE:${PN}-conf-kvm-gateway-demo = "ics-homescreen.yaml"
+ALTERNATIVE_TARGET_${PN}-conf-kvm-gateway-demo = "${sysconfdir}/xdg/AGL/ics-homescreen.yaml.kvm-gateway-demo"
+ALTERNATIVE_PRIORITY_${PN}-conf-kvm-gateway-demo = "31"
diff --git a/recipes-demo/navigation/ondemandnavi/navigation.conf.gateway-demo b/recipes-demo/navigation/ondemandnavi/navigation.conf.gateway-demo
new file mode 100644
index 00000000..ed71a497
--- /dev/null
+++ b/recipes-demo/navigation/ondemandnavi/navigation.conf.gateway-demo
@@ -0,0 +1,4 @@
+[kuksa-client]
+hostname = "192.168.10.4"
+tls-server-name = "localhost"
+authorization = "/etc/xdg/AGL/navigation/navigation.token"
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
index 7bfa0007..cf53b2ba 100644
--- a/recipes-demo/navigation/ondemandnavi_git.bb
+++ b/recipes-demo/navigation/ondemandnavi_git.bb
@@ -13,6 +13,7 @@ PV = "2.0+git${SRCPV}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH} \
file://navigation.conf \
file://navigation.conf.kvm-demo \
+ file://navigation.conf.gateway-demo \
file://navigation.token \
"
SRCREV = "d6b883ef6bdb63fb501b03d64c9a32bc29b7b2c7"
@@ -35,26 +36,33 @@ do_install:append() {
install -d ${D}${sysconfdir}/xdg/AGL/navigation
install -m 0644 ${WORKDIR}/navigation.conf ${D}${sysconfdir}/xdg/AGL/navigation.conf.default
install -m 0644 ${WORKDIR}/navigation.conf.kvm-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/navigation.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/navigation.token ${D}${sysconfdir}/xdg/AGL/navigation/
}
ALTERNATIVE_LINK_NAME[navigation.conf] = "${sysconfdir}/xdg/AGL/navigation.conf"
-PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-kvm-demo"
+PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-kvm-demo ${PN}-conf-gateway-demo"
FILES:${PN}-conf += "${sysconfdir}/xdg/AGL/navigation.conf.default"
RDEPENDS:${PN}-conf = "${PN}"
RPROVIDES:${PN}-conf = "navigation.conf"
-RCONFLICTS:${PN}-conf = "${PN}-conf-kvm-demo"
ALTERNATIVE:${PN}-conf = "navigation.conf"
ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/navigation.conf.default"
+FILES:${PN}-conf-gateway-demo += "${sysconfdir}/xdg/AGL/navigation.conf.gateway-demo"
+RDEPENDS:${PN}-conf-gateway-demo = "${PN}"
+RPROVIDES:${PN}-conf-gateway-demo = "navigation.conf"
+ALTERNATIVE:${PN}-conf-gateway-demo = "navigation.conf"
+ALTERNATIVE_TARGET_${PN}-conf-gateway-demo = "${sysconfdir}/xdg/AGL/navigation.conf.gateway-demo"
+ALTERNATIVE_PRIORITY_${PN}-conf-gateway-demo = "20"
+
FILES:${PN}-conf-kvm-demo += "${sysconfdir}/xdg/AGL/navigation.conf.kvm-demo"
RDEPENDS:${PN}-conf-kvm-demo = "${PN}"
RPROVIDES:${PN}-conf-kvm-demo = "navigation.conf"
-RCONFLICTS:${PN}-conf-kvm-demo = "${PN}-conf"
ALTERNATIVE:${PN}-conf-kvm-demo = "navigation.conf"
ALTERNATIVE_TARGET_${PN}-conf-kvm-demo = "${sysconfdir}/xdg/AGL/navigation.conf.kvm-demo"
+ALTERNATIVE_PRIORITY_${PN}-conf-kvm-demo = "30"
RDEPENDS:${PN} += " \
qtwayland \
diff --git a/recipes-demo/navigation/tbtnavi/tbtnavi.conf.gateway-demo b/recipes-demo/navigation/tbtnavi/tbtnavi.conf.gateway-demo
new file mode 100644
index 00000000..6f528719
--- /dev/null
+++ b/recipes-demo/navigation/tbtnavi/tbtnavi.conf.gateway-demo
@@ -0,0 +1,4 @@
+[kuksa-client]
+hostname = "192.168.10.4"
+tls-server-name = "localhost"
+authorization = "/etc/xdg/AGL/tbtnavi/tbtnavi.token"
diff --git a/recipes-demo/navigation/tbtnavi_git.bb b/recipes-demo/navigation/tbtnavi_git.bb
index b3703c53..3c6571b1 100644
--- a/recipes-demo/navigation/tbtnavi_git.bb
+++ b/recipes-demo/navigation/tbtnavi_git.bb
@@ -28,6 +28,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;b
file://tbtnavi.service \
file://tbtnavi.conf \
file://tbtnavi.conf.kvm-demo \
+ file://tbtnavi.conf.gateway-demo \
file://tbtnavi.token \
file://kvm.conf \
"
@@ -54,6 +55,7 @@ do_install:append() {
install -d ${D}${sysconfdir}/xdg/AGL/tbtnavi
install -m 0644 ${WORKDIR}/tbtnavi.conf ${D}${sysconfdir}/xdg/AGL/tbtnavi.conf.default
install -m 0644 ${WORKDIR}/tbtnavi.conf.kvm-demo ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/tbtnavi.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
install -m 0644 ${WORKDIR}/tbtnavi.token ${D}${sysconfdir}/xdg/AGL/tbtnavi/
}
@@ -68,21 +70,33 @@ RDEPENDS:${PN} += " \
libqtappfw \
"
-PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-kvm-demo"
+PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-kvm ${PN}-conf-kvm-demo ${PN}-conf-gateway-demo"
FILES:${PN}-conf += "${sysconfdir}/xdg/AGL/tbtnavi.conf.default"
RDEPENDS:${PN}-conf = "${PN}"
RPROVIDES:${PN}-conf = "tbtnavi.conf"
-RCONFLICTS:${PN}-conf = "${PN}-conf-kvm-demo"
ALTERNATIVE:${PN}-conf = "tbtnavi.conf"
ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/tbtnavi.conf.default"
+FILES:${PN}-conf-gateway-demo += " \
+ ${sysconfdir}/xdg/AGL/tbtnavi.conf.gateway-demo \
+"
+RDEPENDS:${PN}-conf-gateway-demo = "${PN}"
+RPROVIDES:${PN}-conf-gateway-demo = "tbtnavi.conf"
+ALTERNATIVE:${PN}-conf-gateway-demo = "tbtnavi.conf"
+ALTERNATIVE_TARGET_${PN}-conf-gateway-demo = "${sysconfdir}/xdg/AGL/tbtnavi.conf.gateway-demo"
+ALTERNATIVE_PRIORITY_${PN}-conf-gateway-demo = "20"
+
+FILES:${PN}-conf-kvm += " \
+ ${systemd_system_unitdir}/tbtnavi.service.d/kvm.conf \
+"
+RDEPENDS:${PN}-conf-kvm = "${PN}"
+
FILES:${PN}-conf-kvm-demo += " \
${sysconfdir}/xdg/AGL/tbtnavi.conf.kvm-demo \
- ${systemd_system_unitdir}/tbtnavi.service.d/kvm.conf \
"
-RDEPENDS:${PN}-conf-kvm-demo = "${PN}"
+RDEPENDS:${PN}-conf-kvm-demo = "${PN} ${PN}-conf-kvm"
RPROVIDES:${PN}-conf-kvm-demo = "tbtnavi.conf"
-RCONFLICTS:${PN}-conf-kvm-demo = "${PN}-conf"
ALTERNATIVE:${PN}-conf-kvm-demo = "tbtnavi.conf"
ALTERNATIVE_TARGET_${PN}-conf-kvm-demo = "${sysconfdir}/xdg/AGL/tbtnavi.conf.kvm-demo"
+ALTERNATIVE_PRIORITY_${PN}-conf-kvm-demo = "30"