aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2024-08-18 02:29:42 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-09-09 14:37:44 +0000
commit1f2f47d9ae8d21ace5b74e0c3364e38643088092 (patch)
tree3e2ce78dd665d8b42792f1c4ea7c9c71127b714f /recipes-demo
parent15d8f1f9263e9c6eba2e728aac6a9485e471239b (diff)
Add music data package for demo
Existing AGL demo has music player App. But it did not have demo data. I found classic music provider that provide data by CC-BY-2.1-JP. URL: https://andotowa.quu.cc/ This patch add music data to AGL demo IVI. Bug-AGL: SPEC-5233 Change-Id: I360885bc827f9518b81cf5cd86e2e213a106b8bb Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30184 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-boot-test: Jenkins Job builder account Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30215
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/pre-install/pre-install-music-data.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-demo/pre-install/pre-install-music-data.bb b/recipes-demo/pre-install/pre-install-music-data.bb
new file mode 100644
index 000000000..991f00d31
--- /dev/null
+++ b/recipes-demo/pre-install/pre-install-music-data.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Music data for AGL demo"
+DESCRIPTION = "Music data for AGL demo aims to setup pre-install music data to use AGL demo use. All music data approved redistribution by provider. "
+HOMEPAGE = "https://github.com/agl-ic-eg/demo-music-cache"
+SECTION = "Multimedia"
+LICENSE = "CC-BY-2.1-JP"
+LIC_FILES_CHKSUM = "file://andotowa.quu.cc/LICENSE;md5=f2eaecf5559b657628481f004767cf27"
+
+SRC_URI = " \
+ git://github.com/agl-ic-eg/demo-music-cache.git;branch=master;protocol=https \
+"
+SRCREV = "c300ede365fc64ea759ca696fea676069ef80e01"
+
+inherit allarch
+
+S = "${WORKDIR}/git"
+
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+ERROR_QA:remove = "empty-dirs"
+
+do_compile[noexec] = "1"
+do_install() {
+ install -d ${D}/media/pre-install/andotowa.quu.cc
+ cp ${S}/andotowa.quu.cc/* ${D}/media/pre-install/andotowa.quu.cc/
+}
+
+PACKAGES = "\
+ ${PN} \
+"
+
+FILES:${PN} = " \
+ /media/pre-install/* \
+"