summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-02-24 12:42:52 -0500
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2022-04-13 13:31:22 +0000
commit2c9a791dfad68071e3c2abfe34baeb6b1d8bf07b (patch)
treebbe26636c0f48819ffb2680570f67a5ba24c80aa /recipes-demo
parent07796624b6fe3feaa88990002ce9195b22977bdd (diff)
Add now required pkgconfig inherit to restored app recipes
The pkgconfig class is no longer automatically inherited via dependencies in upstream poky, add the now required explicit inherit in the restored recipes for the mediaplayer, radio, phone, and messaging apps so they will build. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I852ca9f38774e654265f3d09099bf7de60220330
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/mediaplayer/mediaplayer_git.bb2
-rw-r--r--recipes-demo/messaging/messaging_git.bb2
-rw-r--r--recipes-demo/phone/phone_git.bb2
-rw-r--r--recipes-demo/radio/radio_git.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/recipes-demo/mediaplayer/mediaplayer_git.bb b/recipes-demo/mediaplayer/mediaplayer_git.bb
index 7962f76c..31d10201 100644
--- a/recipes-demo/mediaplayer/mediaplayer_git.bb
+++ b/recipes-demo/mediaplayer/mediaplayer_git.bb
@@ -15,7 +15,7 @@ SRCREV = "${AGL_APP_REVISION}"
S = "${WORKDIR}/git"
-inherit qmake5
+inherit qmake5 pkgconfig
FILES:${PN} += "${datadir}/icons/"
diff --git a/recipes-demo/messaging/messaging_git.bb b/recipes-demo/messaging/messaging_git.bb
index 47b3be8e..0da2c9e0 100644
--- a/recipes-demo/messaging/messaging_git.bb
+++ b/recipes-demo/messaging/messaging_git.bb
@@ -15,7 +15,7 @@ SRCREV = "${AGL_APP_REVISION}"
S = "${WORKDIR}/git"
-inherit qmake5
+inherit qmake5 pkgconfig
FILES:${PN} += "${datadir}/icons/"
diff --git a/recipes-demo/phone/phone_git.bb b/recipes-demo/phone/phone_git.bb
index 5e89af53..a5fa443a 100644
--- a/recipes-demo/phone/phone_git.bb
+++ b/recipes-demo/phone/phone_git.bb
@@ -15,7 +15,7 @@ SRCREV = "${AGL_APP_REVISION}"
S = "${WORKDIR}/git"
-inherit qmake5
+inherit qmake5 pkgconfig
FILES:${PN} += "${datadir}/icons/ ${datadir}/sounds/"
diff --git a/recipes-demo/radio/radio_git.bb b/recipes-demo/radio/radio_git.bb
index 326c411a..b98d0fde 100644
--- a/recipes-demo/radio/radio_git.bb
+++ b/recipes-demo/radio/radio_git.bb
@@ -19,7 +19,7 @@ SRCREV = "${AGL_APP_REVISION}"
S = "${WORKDIR}/git"
-inherit qmake5
+inherit qmake5 pkgconfig
# ALS, CES, FOSDEM available
AGL_RADIO_PRESETS_LOCALE ?= "CES"