summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-10-18 11:08:21 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-10-23 07:25:53 +0000
commitd1669c0a75a15d5ea27b40bed933d08d044a4ce8 (patch)
treec031cf12912f45ee44aab11d9f775dd17e515c43 /recipes-demo
parent5e6d1ea451cc8c484ec60382c9ff6726d3703016 (diff)
flutter-ics-homescreen: Add conditional flag to disable voice assistant
- Disable the voice assistant when the agl-offline-voice-agent feature is not enabled. - Adapt SRCREV Bug-AGL: SPEC-5265 Change-Id: I2e99c4c87cb7ea5f4a7bc4d67bc8eb903cc8ae81 Signed-off-by: Anuj Solanki <anuj603362@gmail.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/30443 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
index e03bf1d45..9ef8ba78b 100644
--- a/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
+++ b/recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
@@ -18,7 +18,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;p
file://radio-presets.yaml \
file://kvm.conf \
"
-SRCREV = "f870bbe3c49d421ff8ea561752b3b0a38ad04e96"
+SRCREV = "f8b39a2902e73422259965e724a44c56f49ce103"
S = "${WORKDIR}/git"
@@ -37,6 +37,10 @@ DISABLE_BG_ANIMATION = "-DDISABLE_BKG_ANIMATION=true"
DISABLE_BG_ANIMATION:rcar-gen3 = ""
APP_AOT_EXTRA:append = " ${DISABLE_BG_ANIMATION}"
+# Check for agl-offline-voice-agent feature
+ENABLE_VOICE_ASSISTANT = "${@bb.utils.contains('EXTRA_IMAGE_FEATURES', 'agl-offline-voice-agent', '-DENABLE_VOICE_ASSISTANT=true', '-DENABLE_VOICE_ASSISTANT=false', d)}"
+APP_AOT_EXTRA:append = " ${ENABLE_VOICE_ASSISTANT}"
+
do_install:append() {
install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service