summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-06-17 20:38:01 -0400
committerScott Murray <scott.murray@konsulko.com>2022-06-17 20:38:01 -0400
commitfc3950d16e37b1ec8d0da2aaddb9257a96a00ebf (patch)
tree6bf1c1e1995104abebf9d6f61db4e0a63896bc81 /recipes-demo
parent3629f087c22c65265e1271cb649edf9e89e53a75 (diff)
homescreen: update recipe
Update homescreen app recipe to work with the new VehicleSignals API in libqtappfw. Like the updates previously done for other apps, this means installing the new configuration file and associated JSON web token file for KUKSA.val authorization. Bug-AGL: SPEC-4409 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Iafe7d54331357b3633616f48d10e743813cde0ad
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/homescreen/files/homescreen.conf2
-rw-r--r--recipes-demo/homescreen/files/homescreen.token1
-rw-r--r--recipes-demo/homescreen/homescreen_git.bb13
3 files changed, 16 insertions, 0 deletions
diff --git a/recipes-demo/homescreen/files/homescreen.conf b/recipes-demo/homescreen/files/homescreen.conf
new file mode 100644
index 00000000..3ad29f51
--- /dev/null
+++ b/recipes-demo/homescreen/files/homescreen.conf
@@ -0,0 +1,2 @@
+[vis-client]
+authorization = "/etc/xdg/AGL/homescreen/homescreen.token"
diff --git a/recipes-demo/homescreen/files/homescreen.token b/recipes-demo/homescreen/files/homescreen.token
new file mode 100644
index 00000000..770aadcf
--- /dev/null
+++ b/recipes-demo/homescreen/files/homescreen.token
@@ -0,0 +1 @@
+eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzI1NiJ9.eyJzdWIiOiJrdWtzYS52YWwiLCJpc3MiOiJFY2xpcHNlIEtVS1NBIERldiIsImFkbWluIjp0cnVlLCJpYXQiOjE1MTYyMzkwMjIsImV4cCI6MTc2NzIyNTU5OSwia3Vrc2EtdnNzIjp7IioiOiJydyJ9fQ.QQcVR0RuRJIoasPXYsMGZhdvhLjUalk4GcRaxhh3-0_j3CtVSZ0lTbv_Z3As5BfIYzaMlwUzFGvCVOq2MXVjRK81XOAZ6wIsyKOxva16zjbZryr2V_m3yZ4twI3CPEzJch11_qnhInirHltej-tGg6ySfLaTYeAkw4xYGwENMBBhN5t9odANpScZP_xx5bNfwdW1so6FkV1WhpKlCywoxk_vYZxo187d89bbiu-xOZUa5D-ycFkd1-1rjPXLGE_g5bc4jcQBvNBc-5FDbvt4aJlTQqjpdeppxhxn_gjkPGIAacYDI7szOLC-WYajTStbksUju1iQCyli11kPx0E66me_ZVwOX07f1lRF6D2brWm1LcMAHM3bQUK0LuyVwWPxld64uSAEsvSKsRyJERc7nZUgLf7COnUrrkxgIUNjukbdT2JVN_I-3l3b4YXg6JVD7Y5g0QYBKgXEFpZrDbBVhzo7PXPAhJD6-c3DcUQyRZExbrnFV56RwWuExphw8lYnbMvxPWImiVmB9nRVgFKD0TYaw1sidPSSlZt8Uw34VZzHWIZQAQY0BMjR33fefg42XQ1YzIwPmDx4GYXLl7HNIIVbsRsibKaJnf49mz2qnLC1K272zXSPljO11Ke1MNnsnKyUH7mcwEs9nhTsnMgEOx_TyMLRYo-VEHBDLuEOiBo \ No newline at end of file
diff --git a/recipes-demo/homescreen/homescreen_git.bb b/recipes-demo/homescreen/homescreen_git.bb
index c4556784..29f0678f 100644
--- a/recipes-demo/homescreen/homescreen_git.bb
+++ b/recipes-demo/homescreen/homescreen_git.bb
@@ -22,6 +22,8 @@ PV = "1.0+git${SRCPV}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
file://homescreen.service \
+ file://homescreen.conf \
+ file://homescreen.token \
"
SRCREV = "${AGL_APP_REVISION}"
@@ -37,6 +39,17 @@ do_install:append() {
install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
install -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_user_unitdir}/homescreen.service
ln -s ../homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/homescreen.service
+
+ # Currently using default global client and CA certificates
+ # for KUKSA.val SSL, installing app specific ones would go here.
+
+ # VIS authorization token file for KUKSA.val should ideally not
+ # be readable by other users, but currently that's not doable
+ # until a packaging/sandboxing/MAC scheme is (re)implemented or
+ # something like OAuth is plumbed in as an alternative.
+ install -d ${D}${sysconfdir}/xdg/AGL/homescreen
+ install -m 0644 ${WORKDIR}/homescreen.conf ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${WORKDIR}/homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
}
FILES:${PN} += " ${systemd_user_unitdir}"