summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-07-27 19:41:59 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-27 19:46:37 -0400
commit7e0e397f3c6c91f3cdaae237f9e0d37046cabbd8 (patch)
tree76259d74a9fc2cc4ab625fd7534b0162238a2edc /recipes-demo
parent731adc93b2fed74bc4410dff510fb019d10f253f (diff)
Add agl-ivi-demo-platform-flutter image
Add an image for testing Flutter applications. At present it uses the Qt demo homescreen and launcher until they can be replaced with a Flutter homescreen with equivalent functionality. To allow testing agl-compositor behavior, the packagegroup for the image includes the demo Qt HVAC and dashboard apps in addition to the Flutter "gallery" demo application packaged for launching with applaunchd. The "agl-flutter" build feature has been added as a dependency of "agl-demo" in order for the above to be buildable by default. Bug-AGL: SPEC-4485 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Idf2daa189a15e9cc4bfe2030ac6aa3f5b0331c0c
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/flutter-gallery/flutter-gallery-release_agldemo.inc5
-rw-r--r--recipes-demo/flutter-gallery/flutter-gallery-release_git.bbappend1
2 files changed, 6 insertions, 0 deletions
diff --git a/recipes-demo/flutter-gallery/flutter-gallery-release_agldemo.inc b/recipes-demo/flutter-gallery/flutter-gallery-release_agldemo.inc
new file mode 100644
index 000000000..4a7d3652a
--- /dev/null
+++ b/recipes-demo/flutter-gallery/flutter-gallery-release_agldemo.inc
@@ -0,0 +1,5 @@
+inherit agl-app
+
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "gallery"
+AGL_APP_NAME = "Gallery"
diff --git a/recipes-demo/flutter-gallery/flutter-gallery-release_git.bbappend b/recipes-demo/flutter-gallery/flutter-gallery-release_git.bbappend
new file mode 100644
index 000000000..6a9edecd0
--- /dev/null
+++ b/recipes-demo/flutter-gallery/flutter-gallery-release_git.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'flutter-gallery-release_agldemo.inc', '', d)}
888; font-weight: bold } /* Keyword.Type */ .highlight .m { color: #0000DD; font-weight: bold } /* Literal.Number */ .highlight .s { color: #dd2200; background-color: #fff0f0 } /* Literal.String */ .highlight .na { color: #336699 } /* Name.Attribute */ .highlight .nb { color: #003388 } /* Name.Builtin */ .highlight .nc { color: #bb0066; font-weight: bold } /* Name.Class */ .highlight .no { color: #003366; font-weight: bold } /* Name.Constant */ .highlight .nd { color: #555555 } /* Name.Decorator */ .highlight .ne { color: #bb0066; font-weight: bold } /* Name.Exception */ .highlight .nf { color: #0066bb; font-weight: bold } /* Name.Function */ .highlight .nl { color: #336699; font-style: italic } /* Name.Label */ .highlight .nn { color: #bb0066; font-weight: bold } /* Name.Namespace */ .highlight .py { color: #336699; font-weight: bold } /* Name.Property */ .highlight .nt { color: #bb0066; font-weight: bold } /* Name.Tag */ .highlight .nv { color: #336699 } /* Name.Variable */ .highlight .ow { color: #008800 } /* Operator.Word */ .highlight .w { color: #bbbbbb } /* Text.Whitespace */ .highlight .mb { color: #0000DD; font-weight: bold } /* Literal.Number.Bin */ .highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
SUMMARY = "A minimal container host image"

require recipes-platform/images/agl-image-boot.inc

IMAGE_INSTALL += " \
    kernel-image \
    lxc \
    drm-lease-manager \
    packagegroup-agl-container-feature-logging-host \
"

CONTAINER_IMAGES ??= ""

IMAGE_LINGUAS ?= " "

NO_RECOMMENDATIONS = "1"

IMAGE_ROOTFS_EXTRA_SPACE:append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "" ,d)}"