summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python3-graphql-core_3.2.3.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-05-12 15:09:57 -0400
committerScott Murray <scott.murray@konsulko.com>2023-05-15 18:44:12 +0000
commit6533623201bf90c56a4a611519fab8923e127b2a (patch)
treebe5ebf12a94bd0611aa1e8fdcdbdb2e26aa2328b /recipes-devtools/python/python3-graphql-core_3.2.3.bb
parenteb5c52e3d293d358e114312b35ad9d1a9d4b8ae9 (diff)
Add vss-tools and required dependencies
Add a vss-tools recipe to build the VSS specification tools, and recipes for the python3-anytree, python3-deprecation, and python3-graphql-core modules it requires. The latter will be submitted for meta-python. Bug-AGL: SPEC-4761 Change-Id: Iffe665c0c6f168f3c37b35ce0346cad210d880c5 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-devtools/python/python3-graphql-core_3.2.3.bb')
-rw-r--r--recipes-devtools/python/python3-graphql-core_3.2.3.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-graphql-core_3.2.3.bb b/recipes-devtools/python/python3-graphql-core_3.2.3.bb
new file mode 100644
index 00000000..b12957a4
--- /dev/null
+++ b/recipes-devtools/python/python3-graphql-core_3.2.3.bb
@@ -0,0 +1,12 @@
+SUMMARY = "GraphQL implementation for Python"
+HOMEPAGE = "https://github.com/graphql-python/graphql-core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=73706fb002de2debc52328afd1688817"
+
+PYPI_PACKAGE = "graphql-core"
+
+SRC_URI[sha256sum] = "06d2aad0ac723e35b1cb47885d3e5c45e956a53bc1b209a9fc5369007fe46676"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND += "native nativesdk"