summaryrefslogtreecommitdiffstats
path: root/recipes-extended/agl-qemu-runner/agl-qemu-runner.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-11-23 15:37:20 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-12-14 16:28:00 +0000
commit7aeccbeaf418826795f7f1be4715d857628f8982 (patch)
treeaf356c5c373f8f108d62204191dcb67882a92499 /recipes-extended/agl-qemu-runner/agl-qemu-runner.bb
parent663de2a9c4404f56f032d01aa49b441b42a28521 (diff)
agl-qemu-runner: Add recipes
Add recipes for agl-qemu-runner.sh QEMU wrapper script and template systemd unit, and guest per-image configuration files and systemd unit links for the various demo platform images. The configurations for the demo images can be mixed and matched somewhat, but only one each of IVI and cluster should be used, as there are some static CPU assignments in the configurations. As well, this has only been tested on the AGL reference hardware at present, some rework will likely be required to support other platforms. There is room to add a bbclass to simplify the guest configuration recipes, but that has not been done for now as this approach may be temporary; a switch to libvirtd with appropriate configurations is likely. Bug-AGL: SPEC-4618 Change-Id: Ieefbd4081cca506f915957cc313411a5ed1ece5c Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit dce8116fb1a1b6f3c2976db126d9f923e2fe4c6f)
Diffstat (limited to 'recipes-extended/agl-qemu-runner/agl-qemu-runner.bb')
-rw-r--r--recipes-extended/agl-qemu-runner/agl-qemu-runner.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-extended/agl-qemu-runner/agl-qemu-runner.bb b/recipes-extended/agl-qemu-runner/agl-qemu-runner.bb
new file mode 100644
index 00000000..b3e3a67d
--- /dev/null
+++ b/recipes-extended/agl-qemu-runner/agl-qemu-runner.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL simple QEMU runner script"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd allarch
+
+SRC_URI = "file://agl-qemu-runner.sh \
+ file://agl-qemu-runner@.service \
+"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ # Install template unit
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/agl-qemu-runner@.service ${D}${systemd_system_unitdir}/
+
+ # Install script
+ install -D -m 0755 ${WORKDIR}/agl-qemu-runner.sh ${D}${sbindir}/agl-qemu-runner.sh
+}
+
+FILES:${PN} += "${systemd_system_unitdir}"
+
+RDEPENDS:${PN} += "bash qemu"