summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/kms-conf
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-08 11:15:02 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 13:58:05 +0000
commit41591d4f8c586aa801220fac0924556f406c58bd (patch)
tree85a2803d48a094fb0ba3a76b9e3d0870a4e5edc2 /recipes-graphics/kms-conf
parent4830bcef14e7f49cdc851c646a69c9bb9bd92e82 (diff)
SPEC-3723: restructure meta-agl-demo
All demo related components should be in here now. We keep the packagegroups on purpose for now to stay backward-compatible. v2: layer does pass yocto-check-layer, dependencies adapted v3: remove the dynamic-layer setup, use all-in-one approach v4: Fixed comments from Paul Barker. Tnx! v5: Removed wayland/weston/agl-compositor additions, except for demo specific weston-init bbappend Follow-up changes required later: - massaging packagegroups - scrub of recipes Bug-AGL: SPEC-3723 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I47cefd8c23d46b2cdd063470e3f7d97d5ad952d8
Diffstat (limited to 'recipes-graphics/kms-conf')
-rw-r--r--recipes-graphics/kms-conf/kms-conf/kms.conf8
-rw-r--r--recipes-graphics/kms-conf/kms-conf/m3ulcb/kms.conf12
-rw-r--r--recipes-graphics/kms-conf/kms-conf_1.0.bb12
3 files changed, 32 insertions, 0 deletions
diff --git a/recipes-graphics/kms-conf/kms-conf/kms.conf b/recipes-graphics/kms-conf/kms-conf/kms.conf
new file mode 100644
index 00000000..7fa9686e
--- /dev/null
+++ b/recipes-graphics/kms-conf/kms-conf/kms.conf
@@ -0,0 +1,8 @@
+{
+ "device": "/dev/dri/card0",
+ "outputs": [
+ {
+ "name":"HDMI-A-1"
+ }
+ ]
+}
diff --git a/recipes-graphics/kms-conf/kms-conf/m3ulcb/kms.conf b/recipes-graphics/kms-conf/kms-conf/m3ulcb/kms.conf
new file mode 100644
index 00000000..16ea328f
--- /dev/null
+++ b/recipes-graphics/kms-conf/kms-conf/m3ulcb/kms.conf
@@ -0,0 +1,12 @@
+{
+ "device": "/dev/dri/card0",
+ "outputs": [
+ {
+ "name":"HDMI-A-1"
+ },
+ {
+ "name":"LVDS1",
+ "mode":"off"
+ }
+ ]
+}
diff --git a/recipes-graphics/kms-conf/kms-conf_1.0.bb b/recipes-graphics/kms-conf/kms-conf_1.0.bb
new file mode 100644
index 00000000..b063f65f
--- /dev/null
+++ b/recipes-graphics/kms-conf/kms-conf_1.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "kms configuration file for the qt eglfs platform"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = " \
+ file://kms.conf \
+"
+
+do_install_append() {
+ install -d ${D}/etc
+ install -m 644 ${WORKDIR}/kms.conf ${D}/etc
+}