summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch
diff options
context:
space:
mode:
authorMichael Teyfel <mteyfel@de.adit-jv.com>2018-08-08 17:18:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-10-17 21:09:51 +0000
commit22c95375e2ab1ab229b68ef9607f6a503dc44ccc (patch)
tree06365ff7f1977a3d6f3590d9ccdef7136edd0d87 /recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch
parent1509176b7b160d9e64f41d3de9d6b6ba996df5b5 (diff)
wayland-ivi-extension: Added ivi-id-agent by mtey
As explained in further discussions, the simple-id-agent is a basic example for reference. This commit adds the ivi-id-agent [1]. It is still a reference implementation but already offers more features (like configurations) that should be desirable for AGL. [1] https://github.com/mtey/wayland-ivi-extension/commits/xdg_support_ivi_id_agent Change-Id: I041b81b480be8fd49fded9d9c9824a0dbb3b568f Signed-off-by: Michael Teyfel <mteyfel@de.adit-jv.com>
Diffstat (limited to 'recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch')
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch b/recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch
new file mode 100644
index 00000000..feeef0e2
--- /dev/null
+++ b/recipes-graphics/wayland/wayland-ivi-extension/0001-Added-ivi-id-agent-to-CMake.patch
@@ -0,0 +1,35 @@
+From 48977cb77410247df547063d9d7bcd381fb13cde Mon Sep 17 00:00:00 2001
+From: Michael Teyfel <mteyfel@de.adit-jv.com>
+Date: Fri, 12 Oct 2018 17:12:24 +0200
+Subject: [PATCH 1/3] Added ivi-id-agent to CMake
+
+Signed-off-by: Michael Teyfel <mteyfel@de.adit-jv.com>
+---
+ CMakeLists.txt | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c82136e..33662b9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,6 +23,9 @@ SET(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)
+
+ project(wayland-ivi-extension)
+
++find_package(PkgConfig REQUIRED)
++pkg_check_modules(WESTON weston>=2.0.0 REQUIRED)
++
+ SET(IVI_EXTENSION_VERSION 2.0.2)
+ SET(ILM_API_VERSION 2.0.2)
+
+@@ -35,6 +38,7 @@ add_subdirectory(ivi-layermanagement-api/ilmClient)
+ add_subdirectory(ivi-layermanagement-api/ilmControl)
+ add_subdirectory(ivi-layermanagement-api/test)
+ add_subdirectory(ivi-layermanagement-examples)
++add_subdirectory(ivi-id-agent-modules/ivi-id-agent)
+
+ if(WITH_ILM_INPUT)
+ add_subdirectory(ivi-input-api/ilmInput)
+--
+2.7.4
+