summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch
diff options
context:
space:
mode:
authorMikhail Durnev <mikhail_durnev@mentor.com>2015-10-20 20:57:57 +1000
committerMikhail Durnev <mikhail_durnev@mentor.com>2015-10-23 13:23:27 +1000
commit0535df2c32dc562bd5f7704a599b982bc9e102df (patch)
tree75b95bccbc72362bd1c645ef07b8ca16279b56a1 /recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch
parentd272cfddde1bffa2b31cb5af382198e300d3a619 (diff)
wayland-ivi-extension: Build unit test apps
The wayland-ivi-extension package provides unit test applications. The recipe was modified to build those apps and install them on the target in a separate ipk/rpm package. The test apps are not compatible with ptest. Ctest is required to run them on the target. Change-Id: I937fde52eafc20f38ab7c8ff2d2981cc4f836f33 Signed-off-by: Mikhail Durnev <mikhail_durnev@mentor.com>
Diffstat (limited to 'recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch')
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch b/recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch
new file mode 100644
index 00000000..5371174d
--- /dev/null
+++ b/recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch
@@ -0,0 +1,22 @@
+diff -Naur old/ivi-input-api/test/CMakeLists.txt new/ivi-input-api/test/CMakeLists.txt
+--- old/ivi-input-api/test/CMakeLists.txt 2015-10-19 23:31:13.000000000 +1000
++++ new/ivi-input-api/test/CMakeLists.txt 2015-10-19 23:30:32.000000000 +1000
+@@ -18,6 +18,7 @@
+ ############################################################################
+
+ CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
++SET(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../cmake/modules)
+
+ FIND_PACKAGE(gtest)
+
+diff -Naur old/ivi-layermanagement-api/test/CMakeLists.txt new/ivi-layermanagement-api/test/CMakeLists.txt
+--- old/ivi-layermanagement-api/test/CMakeLists.txt 2015-10-19 23:31:20.000000000 +1000
++++ new/ivi-layermanagement-api/test/CMakeLists.txt 2015-10-19 23:30:48.000000000 +1000
+@@ -18,6 +18,7 @@
+ ############################################################################
+
+ CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
++SET(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../cmake/modules)
+
+ FIND_PACKAGE(gtest)
+