summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-15 14:47:00 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-06-05 15:11:36 +0200
commitb6852864508358930586e083e72cd2912af68674 (patch)
tree4029e33f00bbd0247524d03f7c1689672d85ef9b /recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch
parentfab778caff2041794814df54b51893965381aa66 (diff)
3rd part of the layer/profile rework [2/2]
This is the last part of the layer rework series. Notable changes are: - move demo specific recipes to the demo (dlt, web-runtime mocca-usb) - wayland-ivi-extension moved to the meta-agl-demo layer for now. - web-runtime moved here (from appfw layer to allow console-only builds with appfw) - adapted packagegroups and agl-features v2: squashed with commit on sandbox to form single commit (tnx, Scott) v3: inclusion of old packagegroup-agl-image-ivi (TODO: refactor and include in profile packagegroups. Tnx, Stephane) v4: base packagegroup-agl-demo-platform on packagegroup-agl-profile-graphical-qt5 v5: fix MOST_DRIVERS_append (disable due to FTBS) v6: re-add RDEPENDS for virtual/pulseaudio-config Bug-AGL: SPEC-145 Bug-AGL: SPEC-1422 Change-Id: I20bd5b9a957ea54a7ecd08bd4f8b99a32266c9c8 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch')
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch b/recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch
new file mode 100644
index 00000000..5371174d
--- /dev/null
+++ b/recipes-graphics/wayland/wayland-ivi-extension/cmake-find-gtest.patch
@@ -0,0 +1,22 @@
+diff -Naur old/ivi-input-api/test/CMakeLists.txt new/ivi-input-api/test/CMakeLists.txt
+--- old/ivi-input-api/test/CMakeLists.txt 2015-10-19 23:31:13.000000000 +1000
++++ new/ivi-input-api/test/CMakeLists.txt 2015-10-19 23:30:32.000000000 +1000
+@@ -18,6 +18,7 @@
+ ############################################################################
+
+ CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
++SET(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../cmake/modules)
+
+ FIND_PACKAGE(gtest)
+
+diff -Naur old/ivi-layermanagement-api/test/CMakeLists.txt new/ivi-layermanagement-api/test/CMakeLists.txt
+--- old/ivi-layermanagement-api/test/CMakeLists.txt 2015-10-19 23:31:20.000000000 +1000
++++ new/ivi-layermanagement-api/test/CMakeLists.txt 2015-10-19 23:30:48.000000000 +1000
+@@ -18,6 +18,7 @@
+ ############################################################################
+
+ CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
++SET(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../cmake/modules)
+
+ FIND_PACKAGE(gtest)
+