summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-06-05 17:00:40 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2018-06-05 17:00:40 +0000
commitf0b5fd39013abe170222051f91589a6db6616770 (patch)
treeb3907e478b0a65c400cbcd1e2f735961743dd66c /recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch
parent5c1f34ff690f28179ab308f068d84c909e46b171 (diff)
parentb6852864508358930586e083e72cd2912af68674 (diff)
Merge "3rd part of the layer/profile rework [2/2]"
Diffstat (limited to 'recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch')
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch b/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch
new file mode 100644
index 00000000..df5d616f
--- /dev/null
+++ b/recipes-graphics/wayland/wayland-ivi-extension/disable-sanitizer-tests.patch
@@ -0,0 +1,13 @@
+Index: git/ivi-layermanagement-api/test/CMakeLists.txt
+===================================================================
+--- git.orig/ivi-layermanagement-api/test/CMakeLists.txt
++++ git/ivi-layermanagement-api/test/CMakeLists.txt
+@@ -58,7 +58,7 @@ IF(BUILD_ILM_API_TESTS)
+ )
+
+ SET(GCC_SANITIZER_COMPILE_FLAGS "-fsanitize=address -fsanitize=undefined -fno-sanitize-recover -fstack-protector-all")
+- SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${GCC_SANITIZER_COMPILE_FLAGS}" )
++ SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}" )
+ SET( CMAKE_CXX_LINK_FLAGS "${CMAKE_CXX_LINK_FLAGS} -static-libasan -static-libubsan" )
+
+ ADD_EXECUTABLE(${PROJECT_NAME} ${SRC_FILES})