summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/wayland-ivi-extension_1.1%.bbappend
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-06-05 17:00:40 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2018-06-05 17:00:40 +0000
commitf0b5fd39013abe170222051f91589a6db6616770 (patch)
treeb3907e478b0a65c400cbcd1e2f735961743dd66c /recipes-graphics/wayland/wayland-ivi-extension_1.1%.bbappend
parent5c1f34ff690f28179ab308f068d84c909e46b171 (diff)
parentb6852864508358930586e083e72cd2912af68674 (diff)
Merge "3rd part of the layer/profile rework [2/2]"
Diffstat (limited to 'recipes-graphics/wayland/wayland-ivi-extension_1.1%.bbappend')
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension_1.1%.bbappend27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/wayland-ivi-extension_1.1%.bbappend b/recipes-graphics/wayland/wayland-ivi-extension_1.1%.bbappend
new file mode 100644
index 00000000..9c29dee4
--- /dev/null
+++ b/recipes-graphics/wayland/wayland-ivi-extension_1.1%.bbappend
@@ -0,0 +1,27 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+ENABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=TRUE \
+ -DINSTALL_ILM_API_TESTS:BOOL=TRUE \
+ "
+
+DISABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=FALSE \
+ -DINSTALL_ILM_API_TESTS:BOOL=FALSE \
+ "
+
+PACKAGECONFIG ??= "test"
+PACKAGECONFIG[test] = "${ENABLE_TEST},${DISABLE_TEST},gtest"
+
+SRC_URI_append = "\
+ file://cmake-find-gtest.patch \
+ file://test-path.patch \
+ "
+
+PACKAGES =+ "${PN}-test"
+
+FILES_${PN}-test = "${libdir}/${PN}/test/*/CTestTestfile.cmake \
+ ${libdir}/${PN}/test/ivi-layermanagement-api-test \
+ ${libdir}/${PN}/test/ivi-input-api-test \
+ "
+FILES_${PN}-dbg += "${libdir}/${PN}/test/.debug"
+
+RDEPENDS_${PN}-test += "cmake"