summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-18 09:50:42 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-21 14:35:48 +0000
commit28d9892a442da85ab0a7ba815ce2fd9982e7e29a (patch)
treecf67cab47ddc6125f3afbd53b4cc55382abbf447 /recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
parentc21827ecac183e29c43470a953fa37270f5520c7 (diff)
Update wayland-ivi-extension to 1.11.0
* remove unused recipes wayland-ivi-extension 1.5.0 * fix patch 0001-wayland-ivi-extension-patch-for-wl-shell-emulator.patch for the new version 1.11.0 of wayland-ivi-extension. Bug-AGL: SPEC-411 jsmoeller: readd after accident. early merge & revert Change-Id: I34add4548497a8f7105a9e635a953a98e2780e8c Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh> Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend')
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend b/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
new file mode 100644
index 00000000..16553da6
--- /dev/null
+++ b/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
@@ -0,0 +1,29 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+ENABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=TRUE \
+ -DINSTALL_ILM_API_TESTS:BOOL=TRUE \
+ "
+
+DISABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=FALSE \
+ -DINSTALL_ILM_API_TESTS:BOOL=FALSE \
+ "
+
+PACKAGECONFIG ??= "ilm_input test"
+PACKAGECONFIG[test] = "${ENABLE_TEST},${DISABLE_TEST},gtest"
+
+
+SRC_URI_append = "\
+ file://0001-wayland-ivi-extension-patch-for-wl-shell-emulator.patch \
+ file://cmake-find-gtest.patch \
+ file://test-path.patch \
+ "
+
+PACKAGES =+ "${PN}-test"
+
+FILES_${PN}-test = "${libdir}/${PN}/test/*/CTestTestfile.cmake \
+ ${libdir}/${PN}/test/ivi-layermanagement-api-test \
+ ${libdir}/${PN}/test/ivi-input-api-test \
+ "
+FILES_${PN}-dbg += "${libdir}/${PN}/test/.debug"
+
+RDEPENDS_${PN}-test += "cmake"