summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/web-runtime/web-runtime_0.1.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-06-05 17:00:40 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2018-06-05 17:00:40 +0000
commitf0b5fd39013abe170222051f91589a6db6616770 (patch)
treeb3907e478b0a65c400cbcd1e2f735961743dd66c /recipes-graphics/web-runtime/web-runtime_0.1.bb
parent5c1f34ff690f28179ab308f068d84c909e46b171 (diff)
parentb6852864508358930586e083e72cd2912af68674 (diff)
Merge "3rd part of the layer/profile rework [2/2]"
Diffstat (limited to 'recipes-graphics/web-runtime/web-runtime_0.1.bb')
-rw-r--r--recipes-graphics/web-runtime/web-runtime_0.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-graphics/web-runtime/web-runtime_0.1.bb b/recipes-graphics/web-runtime/web-runtime_0.1.bb
new file mode 100644
index 00000000..75077b69
--- /dev/null
+++ b/recipes-graphics/web-runtime/web-runtime_0.1.bb
@@ -0,0 +1,42 @@
+inherit allarch
+
+SUMMARY = "Provides the 'web-runtime' command"
+DESCRIPTION = "The command 'web-runtime' is an abstraction that allows to "
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "\
+ file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
+ file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
+ file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
+"
+
+RDEPENDS_${PN} = "\
+ qtdeclarative-tools \
+ qtwayland-qmlplugins \
+ qtquickcontrols-qmlplugins \
+"
+
+PROVIDES += "virtual/webruntime"
+# add also RPROVIDES to satisfy the packagegroup
+RPROVIDES_${PN} += "virtual/webruntime"
+
+do_configure() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/web-runtime ${D}${bindir}/web-runtime
+ install -m 0644 ${WORKDIR}/web-runtime.qml ${D}${bindir}/web-runtime.qml
+ install -m 0644 ${WORKDIR}/web-runtime-webkit.qml ${D}${bindir}/web-runtime-webkit.qml
+}
+
+do_install_append_rcar-gen2() {
+ # workaround for porter board: force the use of libEGL provided by mesa at runtime
+ # otherwise, the proprietary libEGL is used and a problem then occurs due to a missing EGL function
+ sed -i 's|^\(exec /usr/bin/qt5/qmlscene\)|LD_PRELOAD=/usr/lib/libEGL.so \1|g' ${D}${bindir}/web-runtime
+}
+
+