summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-11-17 14:20:22 -0500
commit12ad591d3038db609db5290d8bbe809a34c743de (patch)
treedbbcc9a44134a012f531d48132c8803c3940bfa2 /recipes-graphics
parent88c424f8b8c78dfc5520ea9be1866027df4735b8 (diff)
This is effectively a manual cherry-pick and squash of commits: 4249268041b879b3d2bae338d5de88f4f2d54b26 07f4ab8c2833ae5377b97cc9e3820bed67e539d0 from the master branch with additional review and fixups. The intent of these changes is to minimize the effort to backport fixes from the master branch, which has been updated in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4144 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I3b47f1b7d62038b314a17763d24a64f6d4e15e72
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/hmi-debug/hmi-debug_git.bb2
-rw-r--r--recipes-graphics/kms-conf/kms-conf_1.0.bb2
-rw-r--r--recipes-graphics/libhomescreen/libhomescreen_git.bb2
-rw-r--r--recipes-graphics/qlibhomescreen/qlibhomescreen_git.bb2
-rw-r--r--recipes-graphics/ttf-fonts/ttf-dejavu_agldemo.inc8
-rw-r--r--recipes-graphics/wayland/weston-init_agldemo.inc16
6 files changed, 16 insertions, 16 deletions
diff --git a/recipes-graphics/hmi-debug/hmi-debug_git.bb b/recipes-graphics/hmi-debug/hmi-debug_git.bb
index 27fb60d6..84dff74a 100644
--- a/recipes-graphics/hmi-debug/hmi-debug_git.bb
+++ b/recipes-graphics/hmi-debug/hmi-debug_git.bb
@@ -9,7 +9,7 @@ SRC_URI = " \
file://hmi-debug \
"
-FILES_${PN} = " \
+FILES:${PN} = " \
${sysconfdir}/afm/unit.env.d \
"
diff --git a/recipes-graphics/kms-conf/kms-conf_1.0.bb b/recipes-graphics/kms-conf/kms-conf_1.0.bb
index b063f65f..c2ac9c5d 100644
--- a/recipes-graphics/kms-conf/kms-conf_1.0.bb
+++ b/recipes-graphics/kms-conf/kms-conf_1.0.bb
@@ -6,7 +6,7 @@ SRC_URI = " \
file://kms.conf \
"
-do_install_append() {
+do_install:append() {
install -d ${D}/etc
install -m 644 ${WORKDIR}/kms.conf ${D}/etc
}
diff --git a/recipes-graphics/libhomescreen/libhomescreen_git.bb b/recipes-graphics/libhomescreen/libhomescreen_git.bb
index da511c8a..483b11eb 100644
--- a/recipes-graphics/libhomescreen/libhomescreen_git.bb
+++ b/recipes-graphics/libhomescreen/libhomescreen_git.bb
@@ -16,4 +16,4 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libhomescreen.git;protoco
SRCREV = "0d65d54ba63508c0ef545d02e94d5702f9c8ecb3"
S = "${WORKDIR}/git"
-RDEPENDS_${PN} = "agl-service-homescreen"
+RDEPENDS:${PN} = "agl-service-homescreen"
diff --git a/recipes-graphics/qlibhomescreen/qlibhomescreen_git.bb b/recipes-graphics/qlibhomescreen/qlibhomescreen_git.bb
index 09a262eb..a9f1ccf3 100644
--- a/recipes-graphics/qlibhomescreen/qlibhomescreen_git.bb
+++ b/recipes-graphics/qlibhomescreen/qlibhomescreen_git.bb
@@ -4,7 +4,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
DEPENDS = "qtbase libhomescreen"
-RDEPENDS_${PN} = "libhomescreen"
+RDEPENDS:${PN} = "libhomescreen"
inherit qmake5
diff --git a/recipes-graphics/ttf-fonts/ttf-dejavu_agldemo.inc b/recipes-graphics/ttf-fonts/ttf-dejavu_agldemo.inc
index bb47bdc7..08b6aa49 100644
--- a/recipes-graphics/ttf-fonts/ttf-dejavu_agldemo.inc
+++ b/recipes-graphics/ttf-fonts/ttf-dejavu_agldemo.inc
@@ -1,11 +1,11 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-DEPENDS_append = " fontforge-native"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+DEPENDS:append = " fontforge-native"
# From the orginal work located at https://aur.archlinux.org/packages/ttf-dejavu-emojiless/
-SRC_URI_append = " file://cleaner.py"
+SRC_URI:append = " file://cleaner.py"
-do_install_prepend() {
+do_install:prepend() {
for TTF in ${S}/*.ttf; do
fontforge -script ${WORKDIR}/cleaner.py ${TTF}
done
diff --git a/recipes-graphics/wayland/weston-init_agldemo.inc b/recipes-graphics/wayland/weston-init_agldemo.inc
index 56a9d4bf..4815079f 100644
--- a/recipes-graphics/wayland/weston-init_agldemo.inc
+++ b/recipes-graphics/wayland/weston-init_agldemo.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/weston-init:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/weston-init:"
inherit agl-graphical
@@ -6,9 +6,9 @@ AGL_DEFAULT_WESTONSTART ??= "/usr/bin/agl-compositor --config ${sysconfdir}/xdg/
WESTON_USE_PIXMAN ??= "0"
WESTONSTART ??= "${AGL_DEFAULT_WESTONSTART} ${WESTONARGS}"
-WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/compositor.log", "",d)}"
-WESTONSTART_append = " ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", " --debug", "",d)}"
-WESTONSTART_append = " ${@bb.utils.contains("WESTON_USE_PIXMAN", "1", " --use-pixman", "",d)}"
+WESTONSTART:append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/compositor.log", "",d)}"
+WESTONSTART:append = " ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", " --debug", "",d)}"
+WESTONSTART:append = " ${@bb.utils.contains("WESTON_USE_PIXMAN", "1", " --use-pixman", "",d)}"
# Systemd name of DRM device to have weston/agl-compositor startup depend
# upon, if required. Currently only x86-64 seems to need a dependency to
@@ -27,13 +27,13 @@ WIFILES = " \
file://zz-video.rules.in \
"
-WIFILES_append_imx = " \
+WIFILES:append:imx = " \
file://zz-dri-imx.rules.in \
"
-SRC_URI_append = " ${WIFILES}"
+SRC_URI:append = " ${WIFILES}"
-do_install_append() {
+do_install:append() {
# Remove upstream weston udev rules just to be safe
rm -f ${D}${sysconfdir}/udev/rules.d/71-weston-drm.rules
@@ -75,7 +75,7 @@ do_install_append() {
done
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${libdir}/tmpfiles.d/ \
${systemd_system_unitdir}/weston@.service.d/ \
"