summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@gmail.com>2017-06-01 07:46:15 +0000
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-09-06 13:26:25 +0200
commit23237f85ab7553403b69a003c0e8f418e9df6a1d (patch)
tree624f5c5b04bcfdd5fc7e085259bce9090d41add3 /recipes-graphics
parent199f3d33307b86420dc5f127614d91914c56fab1 (diff)
Upgrade to pyro
wayland-ivi-extension: Arrange recipe - Remove unecessary variable in PACKAGECONFIG - Arrange test-path.patch to upgrade wayland-ivi-extension qtbase: Fix build error due to binutils 2.28 bug - gold linker from binutils 2.28 may produce duplicate library symbols, which makes shared libraries created with it not usable with conventional ld linker. - See https://bugs.freebsd.org/bugzilla/attachment.cgi?id=183069&action=diff weston: Change recipe version libdbus-c++: Remove recipe and add bbappend file - meta-openembedded (pyro) already has same version. - Remove PNBLACKLIST[libdbus-c++] to use this component. packagegroups / agl-demo.inc : - move inclusion of qtwebkit out of agl-demo.inc into packagegroup-agl-demo - this fixes an inclusion bug Bug-AGL: SPEC-646 Change-Id: Ia71d5f4dc881f0d8f8f24a5574c9efc0f2da6245 Signed-off-by: Changhyeok Bae <changhyeok.bae@gmail.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension/test-path.patch59
-rw-r--r--recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend3
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend (renamed from recipes-graphics/wayland/weston_1.11.0.bbappend)0
3 files changed, 35 insertions, 27 deletions
diff --git a/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch b/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch
index 9de50187..251bc58f 100644
--- a/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch
+++ b/recipes-graphics/wayland/wayland-ivi-extension/test-path.patch
@@ -1,46 +1,55 @@
-diff -Naur old/ivi-input-api/test/CMakeLists.txt new/ivi-input-api/test/CMakeLists.txt
---- old/ivi-input-api/test/CMakeLists.txt 2015-10-20 00:25:36.000000000 +1000
-+++ new/ivi-input-api/test/CMakeLists.txt 2015-10-20 17:57:45.000000000 +1000
-@@ -66,14 +66,15 @@
+From fbe0d0fd35ff79561dc2da853f1b0903bfde428d Mon Sep 17 00:00:00 2001
+From: Changhyeok Bae <changhyeok.bae@gmail.com>
+Date: Thu, 1 Jun 2017 07:45:20 +0000
+Subject: [PATCH] test patch
+
+---
+ ivi-input-api/test/CMakeLists.txt | 9 +++++----
+ ivi-layermanagement-api/test/CMakeLists.txt | 7 ++++---
+ 2 files changed, 9 insertions(+), 7 deletions(-)
+
+diff --git a/ivi-input-api/test/CMakeLists.txt b/ivi-input-api/test/CMakeLists.txt
+index db05d0f..db3b745 100644
+--- a/ivi-input-api/test/CMakeLists.txt
++++ b/ivi-input-api/test/CMakeLists.txt
+@@ -65,12 +65,13 @@ IF(BUILD_ILM_API_TESTS)
+
ADD_DEPENDENCIES(${PROJECT_NAME} ${LIBS})
- IF(INSTALL_ILM_API_TESTS)
-- INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
-+ INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
-+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-input-api)
- ENDIF()
+- INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
++ INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
++ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-layermanagement-api)
# use CTest
ENABLE_TESTING()
- ADD_TEST(ilmCommon ${PROJECT_NAME})
-- ADD_TEST(ilmClient ${PROJECT_NAME})
- ADD_TEST(ilmControl ${PROJECT_NAME})
- ADD_TEST(ilmInput ${PROJECT_NAME})
-+ ADD_TEST(ilmCommon ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-+ ADD_TEST(ilmClient ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-+ ADD_TEST(ilmControl ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-+ ADD_TEST(ilmInput ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
++ ADD_TEST(ilmCommon {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
++ ADD_TEST(ilmControl {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
++ ADD_TEST(ilmInput {CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
ENDIF()
-diff -Naur old/ivi-layermanagement-api/test/CMakeLists.txt new/ivi-layermanagement-api/test/CMakeLists.txt
---- old/ivi-layermanagement-api/test/CMakeLists.txt 2015-10-20 00:25:36.000000000 +1000
-+++ new/ivi-layermanagement-api/test/CMakeLists.txt 2015-10-20 17:57:24.000000000 +1000
-@@ -64,13 +64,14 @@
+diff --git a/ivi-layermanagement-api/test/CMakeLists.txt b/ivi-layermanagement-api/test/CMakeLists.txt
+index fe9a0a4..090d734 100644
+--- a/ivi-layermanagement-api/test/CMakeLists.txt
++++ b/ivi-layermanagement-api/test/CMakeLists.txt
+@@ -63,11 +63,12 @@ IF(BUILD_ILM_API_TESTS)
+
ADD_DEPENDENCIES(${PROJECT_NAME} ${LIBS})
- IF(INSTALL_ILM_API_TESTS)
-- INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
-+ INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
-+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-layermanagement-api)
- ENDIF()
+- INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
++ INSTALL(TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test)
++ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/CTestTestfile.cmake DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/test/ivi-layermanagement-api)
# use CTest
ENABLE_TESTING()
- ADD_TEST(ilmCommon ${PROJECT_NAME})
-- ADD_TEST(ilmClient ${PROJECT_NAME})
- ADD_TEST(ilmControl ${PROJECT_NAME})
+ ADD_TEST(ilmCommon ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
-+ ADD_TEST(ilmClient ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
+ ADD_TEST(ilmControl ${CMAKE_INSTALL_LIBEXECDIR}/test/${PROJECT_NAME})
ENDIF()
+--
+2.7.4
+
diff --git a/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend b/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
index 5a26c9a1..9c29dee4 100644
--- a/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
+++ b/recipes-graphics/wayland/wayland-ivi-extension_1.11.0.bbappend
@@ -8,10 +8,9 @@ DISABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=FALSE \
-DINSTALL_ILM_API_TESTS:BOOL=FALSE \
"
-PACKAGECONFIG ??= "ilm_input test"
+PACKAGECONFIG ??= "test"
PACKAGECONFIG[test] = "${ENABLE_TEST},${DISABLE_TEST},gtest"
-
SRC_URI_append = "\
file://cmake-find-gtest.patch \
file://test-path.patch \
diff --git a/recipes-graphics/wayland/weston_1.11.0.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index c6979e08..c6979e08 100644
--- a/recipes-graphics/wayland/weston_1.11.0.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend