summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2017-05-16 19:21:25 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-07-06 19:55:25 +0000
commit077a0ef0ac094442ba5da0bd9f3f373c909d155f (patch)
tree9837e5b8d8335d9fa9b7045ababb7b6c6d6316c6 /recipes-graphics
parent2236dc42b7824a5aa0c6841d38500c0ef76512b5 (diff)
weston.ini: Add virtual display and record for CES2017 demo
In order to support IVI-Cluster demo, set virtual display and gst-recorder parameter in weston.ini. v2: If you want to use virtual output system, set "virtual-display" in DISTRO_FEATURES. Then the sample value is enabled. If you want to use transfer system to multi ECU via H.264, set "gst-record" in DISTRO_FEATURES. Note: These system are supported in R-Car M3 only. Change-Id: Ia782d3bc7079c38f30be52c1f6f152d55e1d2e17 Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-ini-conf.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston-ini-conf.bbappend b/recipes-graphics/wayland/weston-ini-conf.bbappend
index b79c5260..635218a6 100644
--- a/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -4,3 +4,28 @@ WESTONIVISHELL[ivi-module] ??= "ivi-controller.so"
WESTONIVISHELL[ivi-input-module] ??= "ivi-input-controller.so"
WESTONSECTION[WESTONIVISHELL] = "ivi-shell"
+
+# IVI cluster and virtual display sample
+python () {
+ if bb.utils.contains('DISTRO_FEATURES', 'virtual-display', True, False, d):
+ d.setVarFlag("WESTONCORE", "virtual", "1")
+}
+
+WESTONOUTPUT2[agl_screen] ??= "SCREEN_VIRTUAL"
+
+WESTONSECTION[WESTONOUTPUT2] = "output"
+
+SCREEN_VIRTUAL[name]?="virtual1"
+SCREEN_VIRTUAL[mode]?="384x368@60"
+
+# If gst-record is set, recorder flag is true
+python () {
+ if bb.utils.contains('DISTRO_FEATURES', 'gst-record', True, False, d):
+ d.setVarFlag("SCREEN_VIRTUAL", "recorder", "true")
+}
+
+SCREEN_VIRTUAL[ip]?="192.168.20.99"
+SCREEN_VIRTUAL[port]?="5005"
+SCREEN_VIRTUAL[bitrate]?="300000"
+SCREEN_VIRTUAL[crop]?="384x368@0x0"
+