summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/aim-cdev
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2016-08-02 11:48:39 +0200
committerChristian Gromm <christian.gromm@microchip.com>2016-08-02 11:48:50 +0200
commit1ea0cef6934ccadc36395b60d8b8d58d69016e28 (patch)
treec3b44cb86f0eb10b125cd8f52d48cb96e31eaaaa /recipes-kernel/aim-cdev
parent9a319937529cca7e263e987b85cb9d6fca0b468c (diff)
recipes-kernel: update driver recipes
This patch changes the recipes to fetch the driver sources from AGL's src directory. It therefore removes the redundant source files from the recipe directory. Change-Id: Ib3c48a0c7e79144713ccd8e10a89185cd929b41c Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Diffstat (limited to 'recipes-kernel/aim-cdev')
-rw-r--r--recipes-kernel/aim-cdev/aim-cdev.bb17
-rw-r--r--recipes-kernel/aim-cdev/files/COPYING340
-rw-r--r--recipes-kernel/aim-cdev/files/Makefile18
-rw-r--r--recipes-kernel/aim-cdev/files/cdev.c550
4 files changed, 7 insertions, 918 deletions
diff --git a/recipes-kernel/aim-cdev/aim-cdev.bb b/recipes-kernel/aim-cdev/aim-cdev.bb
index e2b0bbef..b51fe236 100644
--- a/recipes-kernel/aim-cdev/aim-cdev.bb
+++ b/recipes-kernel/aim-cdev/aim-cdev.bb
@@ -1,21 +1,18 @@
DESCRIPTION = "Example of how to build an external Linux kernel module"
LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
- file://cdev.c;md5=b080105073061d6c4f25e3c2daab2d12 \
- "
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+# "
inherit module
-PR = "r0"
PV = "0.1"
-SRC_URI = "file://Makefile \
- file://../../mostcore/files/mostcore.h \
- file://cdev.c \
- file://COPYING \
- "
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-S = "${WORKDIR}"
+S = "${WORKDIR}/git/driver/${PN}"
+SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
+#SRCREV = "${AUTOREV}"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
diff --git a/recipes-kernel/aim-cdev/files/COPYING b/recipes-kernel/aim-cdev/files/COPYING
deleted file mode 100644
index 6d45519c..00000000
--- a/recipes-kernel/aim-cdev/files/COPYING
+++ /dev/null
@@ -1,340 +0,0 @@
- GNU GENERAL PUBLIC LICENSE
- Version 2, June 1991
-
- Copyright (C) 1989, 1991 Free Software Foundation, Inc.
- 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
- Everyone is permitted to copy and distribute verbatim copies
- of this license document, but changing it is not allowed.
-
- Preamble
-
- The licenses for most software are designed to take away your
-freedom to share and change it. By contrast, the GNU General Public
-License is intended to guarantee your freedom to share and change free
-software--to make sure the software is free for all its users. This
-General Public License applies to most of the Free Software
-Foundation's software and to any other program whose authors commit to
-using it. (Some other Free Software Foundation software is covered by
-the GNU Library General Public License instead.) You can apply it to
-your programs, too.
-
- When we speak of free software, we are referring to freedom, not
-price. Our General Public Licenses are designed to make sure that you
-have the freedom to distribute copies of free software (and charge for
-this service if you wish), that you receive source code or can get it
-if you want it, that you can change the software or use pieces of it
-in new free programs; and that you know you can do these things.
-
- To protect your rights, we need to make restrictions that forbid
-anyone to deny you these rights or to ask you to surrender the rights.
-These restrictions translate to certain responsibilities for you if you
-distribute copies of the software, or if you modify it.
-
- For example, if you distribute copies of such a program, whether
-gratis or for a fee, you must give the recipients all the rights that
-you have. You must make sure that they, too, receive or can get the
-source code. And you must show them these terms so they know their
-rights.
-
- We protect your rights with two steps: (1) copyright the software, and
-(2) offer you this license which gives you legal permission to copy,
-distribute and/or modify the software.
-
- Also, for each author's protection and ours, we want to make certain
-that everyone understands that there is no warranty for this free
-software. If the software is modified by someone else and passed on, we
-want its recipients to know that what they have is not the original, so
-that any problems introduced by others will not reflect on the original
-authors' reputations.
-
- Finally, any free program is threatened constantly by software
-patents. We wish to avoid the danger that redistributors of a free
-program will individually obtain patent licenses, in effect making the
-program proprietary. To prevent this, we have made it clear that any
-patent must be licensed for everyone's free use or not licensed at all.
-
- The precise terms and conditions for copying, distribution and
-modification follow.
-
- GNU GENERAL PUBLIC LICENSE
- TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
-
- 0. This License applies to any program or other work which contains
-a notice placed by the copyright holder saying it may be distributed
-under the terms of this General Public License. The "Program", below,
-refers to any such program or work, and a "work based on the Program"
-means either the Program or any derivative work under copyright law:
-that is to say, a work containing the Program or a portion of it,
-either verbatim or with modifications and/or translated into another
-language. (Hereinafter, translation is included without limitation in
-the term "modification".) Each licensee is addressed as "you".
-
-Activities other than copying, distribution and modification are not
-covered by this License; they are outside its scope. The act of
-running the Program is not restricted, and the output from the Program
-is covered only if its contents constitute a work based on the
-Program (independent of having been made by running the Program).
-Whether that is true depends on what the Program does.
-
- 1. You may copy and distribute verbatim copies of the Program's
-source code as you receive it, in any medium, provided that you
-conspicuously and appropriately publish on each copy an appropriate
-copyright notice and disclaimer of warranty; keep intact all the
-notices that refer to this License and to the absence of any warranty;
-and give any other recipients of the Program a copy of this License
-along with the Program.
-
-You may charge a fee for the physical act of transferring a copy, and
-you may at your option offer warranty protection in exchange for a fee.
-
- 2. You may modify your copy or copies of the Program or any portion
-of it, thus forming a work based on the Program, and copy and
-distribute such modifications or work under the terms of Section 1
-above, provided that you also meet all of these conditions:
-
- a) You must cause the modified files to carry prominent notices
- stating that you changed the files and the date of any change.
-
- b) You must cause any work that you distribute or publish, that in
- whole or in part contains or is derived from the Program or any
- part thereof, to be licensed as a whole at no charge to all third
- parties under the terms of this License.
-
- c) If the modified program normally reads commands interactively
- when run, you must cause it, when started running for such
- interactive use in the most ordinary way, to print or display an
- announcement including an appropriate copyright notice and a
- notice that there is no warranty (or else, saying that you provide
- a warranty) and that users may redistribute the program under
- these conditions, and telling the user how to view a copy of this
- License. (Exception: if the Program itself is interactive but
- does not normally print such an announcement, your work based on
- the Program is not required to print an announcement.)
-
-These requirements apply to the modified work as a whole. If
-identifiable sections of that work are not derived from the Program,
-and can be reasonably considered independent and separate works in
-themselves, then this License, and its terms, do not apply to those
-sections when you distribute them as separate works. But when you
-distribute the same sections as part of a whole which is a work based
-on the Program, the distribution of the whole must be on the terms of
-this License, whose permissions for other licensees extend to the
-entire whole, and thus to each and every part regardless of who wrote it.
-
-Thus, it is not the intent of this section to claim rights or contest
-your rights to work written entirely by you; rather, the intent is to
-exercise the right to control the distribution of derivative or
-collective works based on the Program.
-
-In addition, mere aggregation of another work not based on the Program
-with the Program (or with a work based on the Program) on a volume of
-a storage or distribution medium does not bring the other work under
-the scope of this License.
-
- 3. You may copy and distribute the Program (or a work based on it,
-under Section 2) in object code or executable form under the terms of
-Sections 1 and 2 above provided that you also do one of the following:
-
- a) Accompany it with the complete corresponding machine-readable
- source code, which must be distributed under the terms of Sections
- 1 and 2 above on a medium customarily used for software interchange; or,
-
- b) Accompany it with a written offer, valid for at least three
- years, to give any third party, for a charge no more than your
- cost of physically performing source distribution, a complete
- machine-readable copy of the corresponding source code, to be
- distributed under the terms of Sections 1 and 2 above on a medium
- customarily used for software interchange; or,
-
- c) Accompany it with the information you received as to the offer
- to distribute corresponding source code. (This alternative is
- allowed only for noncommercial distribution and only if you
- received the program in object code or executable form with such
- an offer, in accord with Subsection b above.)
-
-The source code for a work means the preferred form of the work for
-making modifications to it. For an executable work, complete source
-code means all the source code for all modules it contains, plus any
-associated interface definition files, plus the scripts used to
-control compilation and installation of the executable. However, as a
-special exception, the source code distributed need not include
-anything that is normally distributed (in either source or binary
-form) with the major components (compiler, kernel, and so on) of the
-operating system on which the executable runs, unless that component
-itself accompanies the executable.
-
-If distribution of executable or object code is made by offering
-access to copy from a designated place, then offering equivalent
-access to copy the source code from the same place counts as
-distribution of the source code, even though third parties are not
-compelled to copy the source along with the object code.
-
- 4. You may not copy, modify, sublicense, or distribute the Program
-except as expressly provided under this License. Any attempt
-otherwise to copy, modify, sublicense or distribute the Program is
-void, and will automatically terminate your rights under this License.
-However, parties who have received copies, or rights, from you under
-this License will not have their licenses terminated so long as such
-parties remain in full compliance.
-
- 5. You are not required to accept this License, since you have not
-signed it. However, nothing else grants you permission to modify or
-distribute the Program or its derivative works. These actions are
-prohibited by law if you do not accept this License. Therefore, by
-modifying or distributing the Program (or any work based on the
-Program), you indicate your acceptance of this License to do so, and
-all its terms and conditions for copying, distributing or modifying
-the Program or works based on it.
-
- 6. Each time you redistribute the Program (or any work based on the
-Program), the recipient automatically receives a license from the
-original licensor to copy, distribute or modify the Program subject to
-these terms and conditions. You may not impose any further
-restrictions on the recipients' exercise of the rights granted herein.
-You are not responsible for enforcing compliance by third parties to
-this License.
-
- 7. If, as a consequence of a court judgment or allegation of patent
-infringement or for any other reason (not limited to patent issues),
-conditions are imposed on you (whether by court order, agreement or
-otherwise) that contradict the conditions of this License, they do not
-excuse you from the conditions of this License. If you cannot
-distribute so as to satisfy simultaneously your obligations under this
-License and any other pertinent obligations, then as a consequence you
-may not distribute the Program at all. For example, if a patent
-license would not permit royalty-free redistribution of the Program by
-all those who receive copies directly or indirectly through you, then
-the only way you could satisfy both it and this License would be to
-refrain entirely from distribution of the Program.
-
-If any portion of this section is held invalid or unenforceable under
-any particular circumstance, the balance of the section is intended to
-apply and the section as a whole is intended to apply in other
-circumstances.
-
-It is not the purpose of this section to induce you to infringe any
-patents or other property right claims or to contest validity of any
-such claims; this section has the sole purpose of protecting the
-integrity of the free software distribution system, which is
-implemented by public license practices. Many people have made
-generous contributions to the wide range of software distributed
-through that system in reliance on consistent application of that
-system; it is up to the author/donor to decide if he or she is willing
-to distribute software through any other system and a licensee cannot
-impose that choice.
-
-This section is intended to make thoroughly clear what is believed to
-be a consequence of the rest of this License.
-
- 8. If the distribution and/or use of the Program is restricted in
-certain countries either by patents or by copyrighted interfaces, the
-original copyright holder who places the Program under this License
-may add an explicit geographical distribution limitation excluding
-those countries, so that distribution is permitted only in or among
-countries not thus excluded. In such case, this License incorporates
-the limitation as if written in the body of this License.
-
- 9. The Free Software Foundation may publish revised and/or new versions
-of the General Public License from time to time. Such new versions will
-be similar in spirit to the present version, but may differ in detail to
-address new problems or concerns.
-
-Each version is given a distinguishing version number. If the Program
-specifies a version number of this License which applies to it and "any
-later version", you have the option of following the terms and conditions
-either of that version or of any later version published by the Free
-Software Foundation. If the Program does not specify a version number of
-this License, you may choose any version ever published by the Free Software
-Foundation.
-
- 10. If you wish to incorporate parts of the Program into other free
-programs whose distribution conditions are different, write to the author
-to ask for permission. For software which is copyrighted by the Free
-Software Foundation, write to the Free Software Foundation; we sometimes
-make exceptions for this. Our decision will be guided by the two goals
-of preserving the free status of all derivatives of our free software and
-of promoting the sharing and reuse of software generally.
-
- NO WARRANTY
-
- 11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY
-FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN
-OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES
-PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
-OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS
-TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE
-PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING,
-REPAIR OR CORRECTION.
-
- 12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING
-WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR
-REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES,
-INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING
-OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED
-TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY
-YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER
-PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE
-POSSIBILITY OF SUCH DAMAGES.
-
- END OF TERMS AND CONDITIONS
-
- How to Apply These Terms to Your New Programs
-
- If you develop a new program, and you want it to be of the greatest
-possible use to the public, the best way to achieve this is to make it
-free software which everyone can redistribute and change under these terms.
-
- To do so, attach the following notices to the program. It is safest
-to attach them to the start of each source file to most effectively
-convey the exclusion of warranty; and each file should have at least
-the "copyright" line and a pointer to where the full notice is found.
-
- <one line to give the program's name and a brief idea of what it does.>
- Copyright (C) <year> <name of author>
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-
-
-Also add information on how to contact you by electronic and paper mail.
-
-If the program is interactive, make it output a short notice like this
-when it starts in an interactive mode:
-
- Gnomovision version 69, Copyright (C) year name of author
- Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type `show w'.
- This is free software, and you are welcome to redistribute it
- under certain conditions; type `show c' for details.
-
-The hypothetical commands `show w' and `show c' should show the appropriate
-parts of the General Public License. Of course, the commands you use may
-be called something other than `show w' and `show c'; they could even be
-mouse-clicks or menu items--whatever suits your program.
-
-You should also get your employer (if you work as a programmer) or your
-school, if any, to sign a "copyright disclaimer" for the program, if
-necessary. Here is a sample; alter the names:
-
- Yoyodyne, Inc., hereby disclaims all copyright interest in the program
- `Gnomovision' (which makes passes at compilers) written by James Hacker.
-
- <signature of Ty Coon>, 1 April 1989
- Ty Coon, President of Vice
-
-This General Public License does not permit incorporating your program into
-proprietary programs. If your program is a subroutine library, you may
-consider it more useful to permit linking proprietary applications with the
-library. If this is what you want to do, use the GNU Library General
-Public License instead of this License.
diff --git a/recipes-kernel/aim-cdev/files/Makefile b/recipes-kernel/aim-cdev/files/Makefile
deleted file mode 100644
index 05853c26..00000000
--- a/recipes-kernel/aim-cdev/files/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-# Makefile
-#
-
-SRC := $(shell pwd)
-
-obj-m += aim_cdev.o
-aim_cdev-y := cdev.o
-CFLAGS_cdev.o := -I$(src)/../../mostcore/files/
-
-all:
- $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
-
-modules_install:
- $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
-
-clean:
- $(MAKE) -C $(KERNEL_SRC) M=$(SRC) clean
-
diff --git a/recipes-kernel/aim-cdev/files/cdev.c b/recipes-kernel/aim-cdev/files/cdev.c
deleted file mode 100644
index 3a2dbf14..00000000
--- a/recipes-kernel/aim-cdev/files/cdev.c
+++ /dev/null
@@ -1,550 +0,0 @@
-/*
- * cdev.c - Application interfacing module for character devices
- *
- * Copyright (C) 2013-2015 Microchip Technology Germany II GmbH & Co. KG
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * This file is licensed under GPLv2.
- */
-
-#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
-#include <linux/module.h>
-#include <linux/sched.h>
-#include <linux/fs.h>
-#include <linux/slab.h>
-#include <linux/device.h>
-#include <linux/cdev.h>
-#include <linux/poll.h>
-#include <linux/kfifo.h>
-#include <linux/uaccess.h>
-#include <linux/idr.h>
-#include "mostcore.h"
-
-static dev_t aim_devno;
-static struct class *aim_class;
-static struct ida minor_id;
-static unsigned int major;
-static struct most_aim cdev_aim;
-
-struct aim_channel {
- wait_queue_head_t wq;
- spinlock_t unlink; /* synchronization lock to unlink channels */
- struct cdev cdev;
- struct device *dev;
- struct mutex io_mutex;
- struct most_interface *iface;
- struct most_channel_config *cfg;
- unsigned int channel_id;
- dev_t devno;
- size_t mbo_offs;
- DECLARE_KFIFO_PTR(fifo, typeof(struct mbo *));
- int access_ref;
- struct list_head list;
-};
-
-#define to_channel(d) container_of(d, struct aim_channel, cdev)
-static struct list_head channel_list;
-static spinlock_t ch_list_lock;
-
-static inline bool ch_has_mbo(struct aim_channel *c)
-{
- return channel_has_mbo(c->iface, c->channel_id, &cdev_aim) > 0;
-}
-
-static inline bool ch_get_mbo(struct aim_channel *c, struct mbo **mbo)
-{
- *mbo = most_get_mbo(c->iface, c->channel_id, &cdev_aim);
- return *mbo;
-}
-
-static struct aim_channel *get_channel(struct most_interface *iface, int id)
-{
- struct aim_channel *c, *tmp;
- unsigned long flags;
- int found_channel = 0;
-
- spin_lock_irqsave(&ch_list_lock, flags);
- list_for_each_entry_safe(c, tmp, &channel_list, list) {
- if ((c->iface == iface) && (c->channel_id == id)) {
- found_channel = 1;
- break;
- }
- }
- spin_unlock_irqrestore(&ch_list_lock, flags);
- if (!found_channel)
- return NULL;
- return c;
-}
-
-static void stop_channel(struct aim_channel *c)
-{
- struct mbo *mbo;
-
- while (kfifo_out((struct kfifo *)&c->fifo, &mbo, 1))
- most_put_mbo(mbo);
- most_stop_channel(c->iface, c->channel_id, &cdev_aim);
-}
-
-static void destroy_cdev(struct aim_channel *c)
-{
- unsigned long flags;
-
- device_destroy(aim_class, c->devno);
- cdev_del(&c->cdev);
- kfifo_free(&c->fifo);
- spin_lock_irqsave(&ch_list_lock, flags);
- list_del(&c->list);
- spin_unlock_irqrestore(&ch_list_lock, flags);
- ida_simple_remove(&minor_id, MINOR(c->devno));
-}
-
-/**
- * aim_open - implements the syscall to open the device
- * @inode: inode pointer
- * @filp: file pointer
- *
- * This stores the channel pointer in the private data field of
- * the file structure and activates the channel within the core.
- */
-static int aim_open(struct inode *inode, struct file *filp)
-{
- struct aim_channel *c;
- int ret;
-
- c = to_channel(inode->i_cdev);
- filp->private_data = c;
-
- if (((c->cfg->direction == MOST_CH_RX) &&
- ((filp->f_flags & O_ACCMODE) != O_RDONLY)) ||
- ((c->cfg->direction == MOST_CH_TX) &&
- ((filp->f_flags & O_ACCMODE) != O_WRONLY))) {
- pr_info("WARN: Access flags mismatch\n");
- return -EACCES;
- }
-
- mutex_lock(&c->io_mutex);
- if (!c->dev) {
- pr_info("WARN: Device is destroyed\n");
- mutex_unlock(&c->io_mutex);
- return -EBUSY;
- }
-
- if (c->access_ref) {
- pr_info("WARN: Device is busy\n");
- mutex_unlock(&c->io_mutex);
- return -EBUSY;
- }
-
- c->mbo_offs = 0;
- ret = most_start_channel(c->iface, c->channel_id, &cdev_aim);
- if (!ret)
- c->access_ref = 1;
- mutex_unlock(&c->io_mutex);
- return ret;
-}
-
-/**
- * aim_close - implements the syscall to close the device
- * @inode: inode pointer
- * @filp: file pointer
- *
- * This stops the channel within the core.
- */
-static int aim_close(struct inode *inode, struct file *filp)
-{
- struct aim_channel *c = to_channel(inode->i_cdev);
-
- mutex_lock(&c->io_mutex);
- spin_lock(&c->unlink);
- c->access_ref = 0;
- spin_unlock(&c->unlink);
- if (c->dev) {
- stop_channel(c);
- mutex_unlock(&c->io_mutex);
- } else {
- destroy_cdev(c);
- mutex_unlock(&c->io_mutex);
- kfree(c);
- }
- return 0;
-}
-
-/**
- * aim_write - implements the syscall to write to the device
- * @filp: file pointer
- * @buf: pointer to user buffer
- * @count: number of bytes to write
- * @offset: offset from where to start writing
- */
-static ssize_t aim_write(struct file *filp, const char __user *buf,
- size_t count, loff_t *offset)
-{
- int ret;
- size_t actual_len;
- size_t max_len;
- struct mbo *mbo = NULL;
- struct aim_channel *c = filp->private_data;
-
- mutex_lock(&c->io_mutex);
- while (c->dev && !ch_get_mbo(c, &mbo)) {
- mutex_unlock(&c->io_mutex);
-
- if ((filp->f_flags & O_NONBLOCK))
- return -EAGAIN;
- if (wait_event_interruptible(c->wq, ch_has_mbo(c) || !c->dev))
- return -ERESTARTSYS;
- mutex_lock(&c->io_mutex);
- }
-
- if (unlikely(!c->dev)) {
- ret = -EPIPE;
- goto unlock;
- }
-
- max_len = c->cfg->buffer_size;
- actual_len = min(count, max_len);
- mbo->buffer_length = actual_len;
-
- if (copy_from_user(mbo->virt_address, buf, mbo->buffer_length)) {
- ret = -EFAULT;
- goto put_mbo;
- }
-
- ret = most_submit_mbo(mbo);
- if (ret)
- goto put_mbo;
-
- mutex_unlock(&c->io_mutex);
- return actual_len;
-put_mbo:
- most_put_mbo(mbo);
-unlock:
- mutex_unlock(&c->io_mutex);
- return ret;
-}
-
-/**
- * aim_read - implements the syscall to read from the device
- * @filp: file pointer
- * @buf: pointer to user buffer
- * @count: number of bytes to read
- * @offset: offset from where to start reading
- */
-static ssize_t
-aim_read(struct file *filp, char __user *buf, size_t count, loff_t *offset)
-{
- size_t to_copy, not_copied, copied;
- struct mbo *mbo;
- struct aim_channel *c = filp->private_data;
-
- mutex_lock(&c->io_mutex);
- while (c->dev && !kfifo_peek(&c->fifo, &mbo)) {
- mutex_unlock(&c->io_mutex);
- if (filp->f_flags & O_NONBLOCK)
- return -EAGAIN;
- if (wait_event_interruptible(c->wq,
- (!kfifo_is_empty(&c->fifo) ||
- (!c->dev))))
- return -ERESTARTSYS;
- mutex_lock(&c->io_mutex);
- }
-
- /* make sure we don't submit to gone devices */
- if (unlikely(!c->dev)) {
- mutex_unlock(&c->io_mutex);
- return -EIO;
- }
-
- to_copy = min_t(size_t,
- count,
- mbo->processed_length - c->mbo_offs);
-
- not_copied = copy_to_user(buf,
- mbo->virt_address + c->mbo_offs,
- to_copy);
-
- copied = to_copy - not_copied;
-
- c->mbo_offs += copied;
- if (c->mbo_offs >= mbo->processed_length) {
- kfifo_skip(&c->fifo);
- most_put_mbo(mbo);
- c->mbo_offs = 0;
- }
- mutex_unlock(&c->io_mutex);
- return copied;
-}
-
-static unsigned int aim_poll(struct file *filp, poll_table *wait)
-{
- struct aim_channel *c = filp->private_data;
- unsigned int mask = 0;
-
- poll_wait(filp, &c->wq, wait);
-
- if (c->cfg->direction == MOST_CH_RX) {
- if (!kfifo_is_empty(&c->fifo))
- mask |= POLLIN | POLLRDNORM;
- } else {
- if (ch_has_mbo(c))
- mask |= POLLOUT | POLLWRNORM;
- }
- return mask;
-}
-
-/**
- * Initialization of struct file_operations
- */
-static const struct file_operations channel_fops = {
- .owner = THIS_MODULE,
- .read = aim_read,
- .write = aim_write,
- .open = aim_open,
- .release = aim_close,
- .poll = aim_poll,
-};
-
-/**
- * aim_disconnect_channel - disconnect a channel
- * @iface: pointer to interface instance
- * @channel_id: channel index
- *
- * This frees allocated memory and removes the cdev that represents this
- * channel in user space.
- */
-static int aim_disconnect_channel(struct most_interface *iface, int channel_id)
-{
- struct aim_channel *c;
-
- if (!iface) {
- pr_info("Bad interface pointer\n");
- return -EINVAL;
- }
-
- c = get_channel(iface, channel_id);
- if (!c)
- return -ENXIO;
-
- mutex_lock(&c->io_mutex);
- spin_lock(&c->unlink);
- c->dev = NULL;
- spin_unlock(&c->unlink);
- if (c->access_ref) {
- stop_channel(c);
- wake_up_interruptible(&c->wq);
- mutex_unlock(&c->io_mutex);
- } else {
- destroy_cdev(c);
- mutex_unlock(&c->io_mutex);
- kfree(c);
- }
- return 0;
-}
-
-/**
- * aim_rx_completion - completion handler for rx channels
- * @mbo: pointer to buffer object that has completed
- *
- * This searches for the channel linked to this MBO and stores it in the local
- * fifo buffer.
- */
-static int aim_rx_completion(struct mbo *mbo)
-{
- struct aim_channel *c;
-
- if (!mbo)
- return -EINVAL;
-
- c = get_channel(mbo->ifp, mbo->hdm_channel_id);
- if (!c)
- return -ENXIO;
-
- spin_lock(&c->unlink);
- if (!c->access_ref || !c->dev) {
- spin_unlock(&c->unlink);
- return -EFAULT;
- }
- kfifo_in(&c->fifo, &mbo, 1);
- spin_unlock(&c->unlink);
-#ifdef DEBUG_MESG
- if (kfifo_is_full(&c->fifo))
- pr_info("WARN: Fifo is full\n");
-#endif
- wake_up_interruptible(&c->wq);
- return 0;
-}
-
-/**
- * aim_tx_completion - completion handler for tx channels
- * @iface: pointer to interface instance
- * @channel_id: channel index/ID
- *
- * This wakes sleeping processes in the wait-queue.
- */
-static int aim_tx_completion(struct most_interface *iface, int channel_id)
-{
- struct aim_channel *c;
-
- if (!iface) {
- pr_info("Bad interface pointer\n");
- return -EINVAL;
- }
- if ((channel_id < 0) || (channel_id >= iface->num_channels)) {
- pr_info("Channel ID out of range\n");
- return -EINVAL;
- }
-
- c = get_channel(iface, channel_id);
- if (!c)
- return -ENXIO;
- wake_up_interruptible(&c->wq);
- return 0;
-}
-
-/**
- * aim_probe - probe function of the driver module
- * @iface: pointer to interface instance
- * @channel_id: channel index/ID
- * @cfg: pointer to actual channel configuration
- * @parent: pointer to kobject (needed for sysfs hook-up)
- * @name: name of the device to be created
- *
- * This allocates achannel object and creates the device node in /dev
- *
- * Returns 0 on success or error code otherwise.
- */
-static int aim_probe(struct most_interface *iface, int channel_id,
- struct most_channel_config *cfg,
- struct kobject *parent, char *name)
-{
- struct aim_channel *c;
- unsigned long cl_flags;
- int retval;
- int current_minor;
-
- if ((!iface) || (!cfg) || (!parent) || (!name)) {
- pr_info("Probing AIM with bad arguments");
- return -EINVAL;
- }
- c = get_channel(iface, channel_id);
- if (c)
- return -EEXIST;
-
- current_minor = ida_simple_get(&minor_id, 0, 0, GFP_KERNEL);
- if (current_minor < 0)
- return current_minor;
-
- c = kzalloc(sizeof(*c), GFP_KERNEL);
- if (!c) {
- retval = -ENOMEM;
- goto error_alloc_channel;
- }
-
- c->devno = MKDEV(major, current_minor);
- cdev_init(&c->cdev, &channel_fops);
- c->cdev.owner = THIS_MODULE;
- cdev_add(&c->cdev, c->devno, 1);
- c->iface = iface;
- c->cfg = cfg;
- c->channel_id = channel_id;
- c->access_ref = 0;
- spin_lock_init(&c->unlink);
- INIT_KFIFO(c->fifo);
- retval = kfifo_alloc(&c->fifo, cfg->num_buffers, GFP_KERNEL);
- if (retval) {
- pr_info("failed to alloc channel kfifo");
- goto error_alloc_kfifo;
- }
- init_waitqueue_head(&c->wq);
- mutex_init(&c->io_mutex);
- spin_lock_irqsave(&ch_list_lock, cl_flags);
- list_add_tail(&c->list, &channel_list);
- spin_unlock_irqrestore(&ch_list_lock, cl_flags);
- c->dev = device_create(aim_class,
- NULL,
- c->devno,
- NULL,
- "%s", name);
-
- retval = IS_ERR(c->dev);
- if (retval) {
- pr_info("failed to create new device node %s\n", name);
- goto error_create_device;
- }
- kobject_uevent(&c->dev->kobj, KOBJ_ADD);
- return 0;
-
-error_create_device:
- kfifo_free(&c->fifo);
- list_del(&c->list);
-error_alloc_kfifo:
- cdev_del(&c->cdev);
- kfree(c);
-error_alloc_channel:
- ida_simple_remove(&minor_id, current_minor);
- return retval;
-}
-
-static struct most_aim cdev_aim = {
- .name = "cdev",
- .probe_channel = aim_probe,
- .disconnect_channel = aim_disconnect_channel,
- .rx_completion = aim_rx_completion,
- .tx_completion = aim_tx_completion,
-};
-
-static int __init mod_init(void)
-{
- pr_info("init()\n");
-
- INIT_LIST_HEAD(&channel_list);
- spin_lock_init(&ch_list_lock);
- ida_init(&minor_id);
-
- if (alloc_chrdev_region(&aim_devno, 0, 50, "cdev") < 0)
- return -EIO;
- major = MAJOR(aim_devno);
-
- aim_class = class_create(THIS_MODULE, "most_cdev_aim");
- if (IS_ERR(aim_class)) {
- pr_err("no udev support\n");
- goto free_cdev;
- }
-
- if (most_register_aim(&cdev_aim))
- goto dest_class;
- return 0;
-
-dest_class:
- class_destroy(aim_class);
-free_cdev:
- unregister_chrdev_region(aim_devno, 1);
- return -EIO;
-}
-
-static void __exit mod_exit(void)
-{
- struct aim_channel *c, *tmp;
-
- pr_info("exit module\n");
-
- most_deregister_aim(&cdev_aim);
-
- list_for_each_entry_safe(c, tmp, &channel_list, list) {
- destroy_cdev(c);
- kfree(c);
- }
- class_destroy(aim_class);
- unregister_chrdev_region(aim_devno, 1);
- ida_destroy(&minor_id);
-}
-
-module_init(mod_init);
-module_exit(mod_exit);
-MODULE_AUTHOR("Christian Gromm <christian.gromm@microchip.com>");
-MODULE_LICENSE("GPL");
-MODULE_DESCRIPTION("character device AIM for mostcore");