summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/aim-network/aim-network.bb
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2015-12-16 13:42:25 +0100
committerGerrit Code Review <gerrit@172.30.200.200>2015-12-21 14:23:03 +0000
commit45e14d9435eef26cb8afb152a56d9f303192fbdd (patch)
treef070a5714a55d09479800110ba219a16c0fb9b2e /recipes-kernel/aim-network/aim-network.bb
parent565235cf6861f03a8d9d6b2613213509949b44d9 (diff)
recipes-kernel: add MOST driver kernel modules
This commit adds the recipes-kernel directory to the meta-agl-demo layer. It is needed to add the MOST driver to the AGL layer and have it compiled as out-of-tree modules. Change-Id: I38174a2f9a59b0424cfaf2f85f059550422f58f2 Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Diffstat (limited to 'recipes-kernel/aim-network/aim-network.bb')
-rw-r--r--recipes-kernel/aim-network/aim-network.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-kernel/aim-network/aim-network.bb b/recipes-kernel/aim-network/aim-network.bb
new file mode 100644
index 00000000..fb858c00
--- /dev/null
+++ b/recipes-kernel/aim-network/aim-network.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Example of how to build an external Linux kernel module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+ file://networking.c;md5=b8382020c8f8164f883cdb311b66ae69 \
+ "
+
+inherit module
+
+PR = "r0"
+PV = "0.1"
+
+SRC_URI = "file://Makefile \
+ file://../../mostcore/files/mostcore.h \
+ file://networking.h \
+ file://networking.c \
+ file://COPYING \
+ "
+
+S = "${WORKDIR}"
+
+# The inherit of module.bbclass will automatically name module packages with
+# "kernel-module-" prefix as required by the oe-core build environment.