aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/aim-network/files/Makefile
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2015-12-16 13:42:25 +0100
committerGerrit Code Review <gerrit@172.30.200.200>2015-12-21 14:23:03 +0000
commit45e14d9435eef26cb8afb152a56d9f303192fbdd (patch)
treef070a5714a55d09479800110ba219a16c0fb9b2e /recipes-kernel/aim-network/files/Makefile
parent565235cf6861f03a8d9d6b2613213509949b44d9 (diff)
recipes-kernel: add MOST driver kernel modules
This commit adds the recipes-kernel directory to the meta-agl-demo layer. It is needed to add the MOST driver to the AGL layer and have it compiled as out-of-tree modules. Change-Id: I38174a2f9a59b0424cfaf2f85f059550422f58f2 Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Diffstat (limited to 'recipes-kernel/aim-network/files/Makefile')
-rw-r--r--recipes-kernel/aim-network/files/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-kernel/aim-network/files/Makefile b/recipes-kernel/aim-network/files/Makefile
new file mode 100644
index 00000000..75314ff0
--- /dev/null
+++ b/recipes-kernel/aim-network/files/Makefile
@@ -0,0 +1,18 @@
+# Makefile
+#
+
+SRC := $(shell pwd)
+
+obj-m := aim_network.o
+aim_network-y := networking.o
+CFLAGS_networking.o := -I$(src)/../../mostcore/files/
+
+all:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) clean
+