aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/aim-sound/aim-sound.bb
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2017-01-24 13:48:26 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-31 14:26:21 +0000
commit50d06c5bd1d141a1549aafe9cdaceeeb75889e46 (patch)
tree758a5bdf9087a92ef8251fc96054d6873ab16023 /recipes-kernel/aim-sound/aim-sound.bb
parentc3a3974d075836fc700e57b2020f4b5473c89021 (diff)
meta-agl-demo: recipes-kernel: update MOST driver recipes
This patch updates the recipes used to build the MOST driver. Since the driver source directory holds version 1.4.0-stable as of commit f19c18408b515c5e33f96893cbe213d9ab30b904 it also adds backport patches for the MOST sound and networking driver needed to build for porter. v2 (jsmoeller): combine with c8359 Change-Id: Ie56cadf9ef6224afb585fe950a0c3b0aff53b572 Signed-off-by: Christian Gromm <christian.gromm@microchip.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> (cherry picked from commit 853bd2c5ee8fb08c8654b1a07e154b66972b49ab)
Diffstat (limited to 'recipes-kernel/aim-sound/aim-sound.bb')
-rw-r--r--recipes-kernel/aim-sound/aim-sound.bb11
1 files changed, 3 insertions, 8 deletions
diff --git a/recipes-kernel/aim-sound/aim-sound.bb b/recipes-kernel/aim-sound/aim-sound.bb
index 3740d257..ae8d7d8b 100644
--- a/recipes-kernel/aim-sound/aim-sound.bb
+++ b/recipes-kernel/aim-sound/aim-sound.bb
@@ -1,18 +1,16 @@
-DESCRIPTION = "Example of how to build an external Linux kernel module"
+DESCRIPTION = "Build ALSA driver for MOST"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
-# "
inherit module
PV = "0.1"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
+SRC_URI_append_porter = " file://0001-aim-sound-3.10.31-ltsi-backport.patch"
S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
-#SRCREV = "${AUTOREV}"
+SRCREV = "${AUTOREV}"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
@@ -24,6 +22,3 @@ do_install_append () {
echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
fi
}
-
-# These sources are currently for the porter kernel only
-COMPATIBLE_MACHINE = "porter"