aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/aim-sound/files/Makefile
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-12-22 00:46:19 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-12-22 00:48:01 +0100
commitdf9e0ad632b122e19964d2f39588fb5fe2087037 (patch)
treef896d3cefff09a33ff87f0dafe61db7c3c7ab9b3 /recipes-kernel/aim-sound/files/Makefile
parente10617b85d81591de2a5b567d43a1f48cc15aa5f (diff)
parent762181dff011efbaf3d40edb1b3d573c5aceab01 (diff)
Merge branch 'master' of ssh://gerrit.automotivelinux.org:29418/AGL/meta-agl-demo into albacore
Change-Id: Ieedfdda7a1be86c626c6f67b57fed05adb628a87 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-kernel/aim-sound/files/Makefile')
-rw-r--r--recipes-kernel/aim-sound/files/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-kernel/aim-sound/files/Makefile b/recipes-kernel/aim-sound/files/Makefile
new file mode 100644
index 00000000..9defcc5e
--- /dev/null
+++ b/recipes-kernel/aim-sound/files/Makefile
@@ -0,0 +1,18 @@
+# Makefile
+#
+
+SRC := $(shell pwd)
+
+obj-m += aim_sound.o
+aim_sound-y := sound.o
+CFLAGS_sound.o := -I$(src)/../../mostcore/files/
+
+all:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) clean
+