summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/aim-v4l2/aim-v4l2.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-12-22 00:46:19 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2015-12-22 00:48:01 +0100
commitdf9e0ad632b122e19964d2f39588fb5fe2087037 (patch)
treef896d3cefff09a33ff87f0dafe61db7c3c7ab9b3 /recipes-kernel/aim-v4l2/aim-v4l2.bb
parente10617b85d81591de2a5b567d43a1f48cc15aa5f (diff)
parent762181dff011efbaf3d40edb1b3d573c5aceab01 (diff)
Merge branch 'master' of ssh://gerrit.automotivelinux.org:29418/AGL/meta-agl-demo into albacore
Change-Id: Ieedfdda7a1be86c626c6f67b57fed05adb628a87 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-kernel/aim-v4l2/aim-v4l2.bb')
-rw-r--r--recipes-kernel/aim-v4l2/aim-v4l2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/aim-v4l2/aim-v4l2.bb b/recipes-kernel/aim-v4l2/aim-v4l2.bb
new file mode 100644
index 000000000..597e1af82
--- /dev/null
+++ b/recipes-kernel/aim-v4l2/aim-v4l2.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Example of how to build an external Linux kernel module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+ file://video.c;md5=9c5e932b69bc0074cf2a62f7977ad3dc \
+ "
+
+inherit module
+
+PR = "r0"
+PV = "0.1"
+
+SRC_URI = "file://Makefile \
+ file://../../mostcore/files/mostcore.h \
+ file://video.c \
+ file://COPYING \
+ "
+
+S = "${WORKDIR}"
+
+# The inherit of module.bbclass will automatically name module packages with
+# "kernel-module-" prefix as required by the oe-core build environment.