summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux_agldemo.inc
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-06-27 14:23:29 -0400
committerScott Murray <scott.murray@konsulko.com>2021-06-27 15:10:59 -0400
commit6e44449dadb99d905a5a9e7fdb7a799785c56f8a (patch)
treef41ec867f7125ac5127498b3d98bc36f09b2851e /recipes-kernel/linux/linux_agldemo.inc
parentcae1c2f734a437262dfeba0f2fb9086eae52dc83 (diff)
Add kernel configuration bbappend
Add linux-%.bbappend and associated conditional .inc file to supply demo-related kernel configuration using the new AGL_KCONFIG_FRAGMENTS variable scheme that is being added in meta-agl-core. The moved configuration fragments are copies of the ones from meta-agl-core except for: - The configuration from the previously linux-yocto-specific hciuart.cfg has been rationalized with btusb.cfg and hid.cfg. - The actual CAN hardware device support from can-bus.cfg has been moved to a new can-devices.cfg here. - To simplify things, the disable_most.cfg configuration to ensure that the upstream kernel MOST driver is disabled to avoid conflicting with the externally built AGL version has been made generic instead of being specific to the Kingfisher support in meta-agl-bsp. It has also been updated a bit for newer kernels. Bug-AGL: SPEC-3983 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I32e4da1ca53e9395239b47ab2191a88e3cd39d4c
Diffstat (limited to 'recipes-kernel/linux/linux_agldemo.inc')
-rw-r--r--recipes-kernel/linux/linux_agldemo.inc38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux_agldemo.inc b/recipes-kernel/linux/linux_agldemo.inc
new file mode 100644
index 00000000..84b61df0
--- /dev/null
+++ b/recipes-kernel/linux/linux_agldemo.inc
@@ -0,0 +1,38 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
+
+# Enable assorted USB device support for demo systems
+AGL_KCONFIG_FRAGMENTS += " \
+ usb.cfg \
+ uvc.cfg \
+ hid.cfg \
+ joystick.cfg \
+ usbaudio.cfg \
+ usbmodem.cfg \
+ btusb.cfg \
+ i2c-led.cfg \
+"
+
+# Enable CAN device support
+AGL_KCONFIG_FRAGMENTS += "can-devices.cfg"
+
+# Enable NFC support
+AGL_KCONFIG_FRAGMENTS += "nfc.cfg"
+
+# Enable support for TP-Link TL-W722N USB Wifi adapter (rev 1 and 2)
+AGL_KCONFIG_FRAGMENTS += "wifi.cfg"
+
+# Enable support for RTLSDR
+AGL_KCONFIG_FRAGMENTS += "rtl_sdr.cfg"
+
+# iio-dummy-device support for test IIO device
+AGL_KCONFIG_FRAGMENTS += "iiodevice.cfg"
+
+# External rtc support via e.g. http://wiki.seeedstudio.com/Grove-RTC/
+AGL_KCONFIG_FRAGMENTS += "rtc.cfg"
+
+# Make sure in-kernel MOST drivers are disabled to avoid conflicting
+# with our externally built ones
+AGL_KCONFIG_FRAGMENTS += "disable_most.cfg"
+
+# Enable some things on qemuarm64 so MOST drivers will build and load.
+AGL_KCONFIG_FRAGMENTS_append_qemuarm64 = " most_deps.cfg"