aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/mocca-usb/_files/Makefile
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2016-08-02 11:48:39 +0200
committerChristian Gromm <christian.gromm@microchip.com>2016-08-02 11:48:50 +0200
commit1ea0cef6934ccadc36395b60d8b8d58d69016e28 (patch)
treec3b44cb86f0eb10b125cd8f52d48cb96e31eaaaa /recipes-kernel/mocca-usb/_files/Makefile
parent9a319937529cca7e263e987b85cb9d6fca0b468c (diff)
recipes-kernel: update driver recipes
This patch changes the recipes to fetch the driver sources from AGL's src directory. It therefore removes the redundant source files from the recipe directory. Change-Id: Ib3c48a0c7e79144713ccd8e10a89185cd929b41c Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Diffstat (limited to 'recipes-kernel/mocca-usb/_files/Makefile')
-rw-r--r--recipes-kernel/mocca-usb/_files/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-kernel/mocca-usb/_files/Makefile b/recipes-kernel/mocca-usb/_files/Makefile
new file mode 100644
index 00000000..fd82dbcd
--- /dev/null
+++ b/recipes-kernel/mocca-usb/_files/Makefile
@@ -0,0 +1,17 @@
+# Makefile
+#
+
+SRC := $(shell pwd)
+
+obj-m += mocca_usb.o
+CFLAGS_hdm_usb.o := -I$(src)/../../aim-network/files/ -I$(src)/../../mostcore/files
+
+all:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) clean
+