aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/mocca-usb/_files/Makefile
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2016-08-02 11:48:39 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-08-04 07:17:20 +0000
commit7b58e8b4d4cd279b00124e50cbbc70b01248a0ee (patch)
tree3387ff74f5957fabe01a26f683ae84813436d32a /recipes-kernel/mocca-usb/_files/Makefile
parent7e3a1a0442347e0290133707aa70e207bce47a99 (diff)
recipes-kernel: update driver recipes
This patch changes the recipes to fetch the driver sources from AGL's src directory. It therefore removes the redundant source files from the recipe directory. Change-Id: Ib3c48a0c7e79144713ccd8e10a89185cd929b41c Signed-off-by: Christian Gromm <christian.gromm@microchip.com> (cherry picked from commit 1ea0cef6934ccadc36395b60d8b8d58d69016e28)
Diffstat (limited to 'recipes-kernel/mocca-usb/_files/Makefile')
-rw-r--r--recipes-kernel/mocca-usb/_files/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-kernel/mocca-usb/_files/Makefile b/recipes-kernel/mocca-usb/_files/Makefile
new file mode 100644
index 00000000..fd82dbcd
--- /dev/null
+++ b/recipes-kernel/mocca-usb/_files/Makefile
@@ -0,0 +1,17 @@
+# Makefile
+#
+
+SRC := $(shell pwd)
+
+obj-m += mocca_usb.o
+CFLAGS_hdm_usb.o := -I$(src)/../../aim-network/files/ -I$(src)/../../mostcore/files
+
+all:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) clean
+