summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/most/files/0001-aim-network-3.10.31-ltsi-backport.patch
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2017-06-09 11:27:04 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-12 08:34:59 +0000
commita22fe6936f2256b4e8f23d6f7e2494b8e6ac7a65 (patch)
tree015b0559d8bf004417c3b1360641cb9d65b62938 /recipes-kernel/most/files/0001-aim-network-3.10.31-ltsi-backport.patch
parent13abc8463dbacc672769f66f27d926cc13524d97 (diff)
fix MOST driver dependency issues
This patch adds a new "most" receipe for building the MOST driver. The receipe replaces the old ones, as it builds all modules at once. Hence, the receipes aim*, hdm* and mostcore are removed. Additionally, the *.bb file for the demo platform is modified to reflect these changes. This patch is needed to avoid dependency issues among the modules of the driver stack. Although, the problem has been reported with SPEC 438 and a patch set to fix it has been introduced with Change #8447, it is still present on RaspberryPi. Change-Id: Id6104ee6d9bf1b7d9744761a6529461176fdd8b2 Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Diffstat (limited to 'recipes-kernel/most/files/0001-aim-network-3.10.31-ltsi-backport.patch')
-rw-r--r--recipes-kernel/most/files/0001-aim-network-3.10.31-ltsi-backport.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-kernel/most/files/0001-aim-network-3.10.31-ltsi-backport.patch b/recipes-kernel/most/files/0001-aim-network-3.10.31-ltsi-backport.patch
new file mode 100644
index 00000000..d0bbd72e
--- /dev/null
+++ b/recipes-kernel/most/files/0001-aim-network-3.10.31-ltsi-backport.patch
@@ -0,0 +1,45 @@
+From 4c49b7ad9e3c1e64e4e6042e6fee357b5d9b3df2 Mon Sep 17 00:00:00 2001
+From: Christian Gromm <christian.gromm@microchip.com>
+Date: Mon, 23 Jan 2017 14:57:55 +0100
+Subject: [PATCH] aim-network: create backport patch for 3.10.31-ltsi
+
+Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
+---
+ aim-network/networking.c | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/aim-network/networking.c b/aim-network/networking.c
+index ce1764c..e04b523 100644
+--- a/aim-network/networking.c
++++ b/aim-network/networking.c
+@@ -362,8 +362,7 @@ static int aim_probe_channel(struct most_interface *iface, int channel_idx,
+
+ if (nd->tx.linked || nd->rx.linked) {
+ struct net_device *dev =
+- alloc_netdev(0, "meth%d", NET_NAME_UNKNOWN,
+- most_nd_setup);
++ alloc_netdev(0, "meth%d", most_nd_setup);
+
+ if (!dev) {
+ pr_err("no memory for net_device\n");
+@@ -483,7 +482,7 @@ static int aim_rx_data(struct mbo *mbo)
+
+ if (nd->is_mamac) {
+ /* dest */
+- ether_addr_copy(skb_put(skb, ETH_ALEN), dev->dev_addr);
++ memcpy(skb_put(skb, ETH_ALEN), dev->dev_addr, ETH_ALEN);
+
+ /* src */
+ memcpy(skb_put(skb, 4), &zero, 4);
+@@ -577,7 +576,7 @@ void most_deliver_netinfo(struct most_interface *iface,
+ if (!is_valid_ether_addr(dev->dev_addr)) {
+ netdev_info(dev, "set mac %02x-%02x-%02x-%02x-%02x-%02x\n",
+ m[0], m[1], m[2], m[3], m[4], m[5]);
+- ether_addr_copy(dev->dev_addr, m);
++ memcpy(dev->dev_addr, m, ETH_ALEN);
+ complete(&nd->mac_compl);
+ } else if (!ether_addr_equal(dev->dev_addr, m)) {
+ netdev_warn(dev, "reject mac %02x-%02x-%02x-%02x-%02x-%02x\n",
+--
+2.11.0
+