summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/most/files/0004-most-video-set-device_caps.patch
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2017-09-04 17:21:29 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-09-26 21:00:22 +0000
commite3253ac2cbc5fb9df6fcc6df6b0de1db34490abf (patch)
treee6a230b2ff138ac410ae11a0ca2b0b94e58a9358 /recipes-kernel/most/files/0004-most-video-set-device_caps.patch
parentc3b43f6db27847fec4588e709d6d16f24065655c (diff)
recipes-kernel: most: add most.bbappend file
This patch adds a patch queue to eliminate problems DMA coherent memory allocation on aarch64 architecture, prevents the driver from printing warning, due to bad video driver capabilities and passes a valid parent device to the sound subsystem when registering a new sound card. --- v2 (jsmoeller): use _append everywhere v3 (christian gromm): fix path in patch files Change-Id: Idceefee7855445481eeb4940d5c5f632e27feb73 Signed-off-by: Christian Gromm <christian.gromm@microchip.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-kernel/most/files/0004-most-video-set-device_caps.patch')
-rw-r--r--recipes-kernel/most/files/0004-most-video-set-device_caps.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-kernel/most/files/0004-most-video-set-device_caps.patch b/recipes-kernel/most/files/0004-most-video-set-device_caps.patch
new file mode 100644
index 00000000..010d4b0d
--- /dev/null
+++ b/recipes-kernel/most/files/0004-most-video-set-device_caps.patch
@@ -0,0 +1,25 @@
+From a5fd2ae8d4a3b2a8f7a33a4ea469ea7ee0d946ef Mon Sep 17 00:00:00 2001
+From: Christian Gromm <christian.gromm@microchip.com>
+Date: Mon, 4 Sep 2017 15:36:38 +0200
+Subject: [PATCH 4/5] most: video: set device_caps
+
+Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
+---
+ driver/aim-v4l2/video.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/aim-v4l2/video.c b/aim-v4l2/video.c
+index e074841..6405a03 100644
+--- a/aim-v4l2/video.c
++++ b/aim-v4l2/video.c
+@@ -263,6 +263,7 @@ static int vidioc_querycap(struct file *file, void *priv,
+ snprintf(cap->bus_info, sizeof(cap->bus_info),
+ "%s", mdev->iface->description);
+
++ cap->device_caps =
+ cap->capabilities =
+ V4L2_CAP_READWRITE |
+ V4L2_CAP_TUNER |
+--
+2.7.4
+