summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/most/files/0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2017-09-04 17:21:29 +0200
committerChristian Gromm <christian.gromm@microchip.com>2017-09-26 12:24:27 +0200
commitd66de47398e0644f2177dc9f1a8ee081c533fd7a (patch)
tree869979e56f367bc8104287e91570c64ac3f63386 /recipes-kernel/most/files/0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch
parent1c2105900332ae31a622131598780cf58c7028c3 (diff)
recipes-kernel: most: add most.bbappend file
This patch adds a patch queue to eliminate problems DMA coherent memory allocation on aarch64 architecture, prevents the driver from printing warning, due to bad video driver capabilities and passes a valid parent device to the sound subsystem when registering a new sound card. --- v2 (jsmoeller): use _append everywhere v3 (christian gromm): fix path in patch files Change-Id: Idceefee7855445481eeb4940d5c5f632e27feb73 Signed-off-by: Christian Gromm <christian.gromm@microchip.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-kernel/most/files/0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch')
-rw-r--r--recipes-kernel/most/files/0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-kernel/most/files/0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch b/recipes-kernel/most/files/0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch
new file mode 100644
index 00000000..ebaee9e1
--- /dev/null
+++ b/recipes-kernel/most/files/0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch
@@ -0,0 +1,25 @@
+From 7518453386ad3e82008186a6c9ca86ed8c136801 Mon Sep 17 00:00:00 2001
+From: Christian Gromm <christian.gromm@microchip.com>
+Date: Mon, 4 Sep 2017 16:08:38 +0200
+Subject: [PATCH 5/5] most: video: set V4L2_CAP_DEVICE_CAPS flag
+
+Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
+---
+ driver/aim-v4l2/video.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/aim-v4l2/video.c b/aim-v4l2/video.c
+index 6405a03..db75d4d 100644
+--- a/aim-v4l2/video.c
++++ b/aim-v4l2/video.c
+@@ -265,6 +265,7 @@ static int vidioc_querycap(struct file *file, void *priv,
+
+ cap->device_caps =
+ cap->capabilities =
++ V4L2_CAP_DEVICE_CAPS |
+ V4L2_CAP_READWRITE |
+ V4L2_CAP_TUNER |
+ V4L2_CAP_VIDEO_CAPTURE;
+--
+2.7.4
+