summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/mostcore/mostcore.bb
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2016-08-02 11:48:39 +0200
committerChristian Gromm <christian.gromm@microchip.com>2016-08-02 11:48:50 +0200
commit1ea0cef6934ccadc36395b60d8b8d58d69016e28 (patch)
treec3b44cb86f0eb10b125cd8f52d48cb96e31eaaaa /recipes-kernel/mostcore/mostcore.bb
parent9a319937529cca7e263e987b85cb9d6fca0b468c (diff)
recipes-kernel: update driver recipes
This patch changes the recipes to fetch the driver sources from AGL's src directory. It therefore removes the redundant source files from the recipe directory. Change-Id: Ib3c48a0c7e79144713ccd8e10a89185cd929b41c Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Diffstat (limited to 'recipes-kernel/mostcore/mostcore.bb')
-rw-r--r--recipes-kernel/mostcore/mostcore.bb17
1 files changed, 7 insertions, 10 deletions
diff --git a/recipes-kernel/mostcore/mostcore.bb b/recipes-kernel/mostcore/mostcore.bb
index 53397552..3a2e1cfe 100644
--- a/recipes-kernel/mostcore/mostcore.bb
+++ b/recipes-kernel/mostcore/mostcore.bb
@@ -1,21 +1,18 @@
DESCRIPTION = "Example of how to build an external Linux kernel module"
LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
- file://core.c;md5=a47d4154c42744ac4ea233372ddf975d \
- "
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+#LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+# "
inherit module
-PR = "r0"
PV = "0.1"
-SRC_URI = "file://Makefile \
- file://core.c \
- file://mostcore.h \
- file://COPYING \
- "
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-S = "${WORKDIR}"
+S = "${WORKDIR}/git/driver/${PN}"
+SRCREV = "7850efa9077fa84536e0442c65d39a36e25e39d1"
+#SRCREV = "${AUTOREV}"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.