aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/sllin/files/0001_update_makefile.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-10-31 15:01:52 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-11-02 12:39:33 +0000
commitb3610d066f49a64e1c0c9f366ec1420e101a389d (patch)
tree199d5609a0f3696b7bfcf0c518c2ef39c3ce4115 /recipes-kernel/sllin/files/0001_update_makefile.patch
parentd5955172359d79a1929a3a40903a31e1ec9f8655 (diff)
Add package for sllin driver to image
The sllin driver is needed for the AGL demo unit to drive the actuator and fan. Change-Id: I76a8e7876148b6c2fcbc526a64a7ec132668c754 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> (cherry picked from commit d30e570a35bf60b8c78b804608af2fe13a69e41d)
Diffstat (limited to 'recipes-kernel/sllin/files/0001_update_makefile.patch')
-rw-r--r--recipes-kernel/sllin/files/0001_update_makefile.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/sllin/files/0001_update_makefile.patch b/recipes-kernel/sllin/files/0001_update_makefile.patch
new file mode 100644
index 00000000..7db57802
--- /dev/null
+++ b/recipes-kernel/sllin/files/0001_update_makefile.patch
@@ -0,0 +1,21 @@
+diff --git a/sllin/Makefile b/sllin/Makefile
+index 8ae7510..037846f 100644
+--- a/sllin/Makefile
++++ b/sllin/Makefile
+@@ -1,10 +1,11 @@
+ obj-m += sllin.o
+-KPATH=/lib/modules/$(shell uname -r)/build
++KPATH=$(KERNEL_SRC)
+ #KPATH=/mnt/data/_dokumenty_/_w_/_dce_can_/src/can-benchmark/kernel/build/shark/3.0.4
+ #KPATH=/mnt/data/_dokumenty_/_w_/_dce_can_/src/can-benchmark/kernel/build/shark/2.6.36
+-
++SRC := $(shell pwd)
+ all:
+- make -C ${KPATH} M=$(PWD) modules
+-
++ make -C ${KPATH} M=$(SRC) modules
++modules_install:
++ make -C ${KPATH} M=$(SRC) modules_install
+ clean:
+- make -C ${KPATH} M=$(PWD) clean
++ make -C ${KPATH} M=$(SRC) clean