summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/sllin/sllin.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-08-19 18:37:51 -0400
committerScott Murray <scott.murray@konsulko.com>2020-08-19 18:37:51 -0400
commit5bdba822918cfffb69c0e1983661c32586bed590 (patch)
treeb1fa11566e42190acc9b9cdda912a7cf2ed50ded /recipes-kernel/sllin/sllin.bb
parent1677ce2027c49763ec186018f8cbf8fcec64c04f (diff)
Add can-dev-mapping-helperjellyfish_9.99.3jellyfish/9.99.39.99.3
Changes: - Add a can-dev-mapping-helper.sh script and systemd unit to drive it, the script checks if the CAN devices specified in the low-can configuration file /etc/dev-mapping.conf exist, and if not brings up corresponding virtual CAN devices. - Add a systemd over-ride conf file for agl-service-can-low-level that makes can-dev-mapping-helper a dependency. This should ensure that the low-can binding always starts even if there are no physical CAN hardware devices. - Added a Before statement to sllin-demo.service to ensure that it will run before can-dev-mapping-helper and ensure that lin_config can create sllin0 correctly. - Removed the sllin-demo-virtual systemd unit, as it will no longer be required with can-dev-mapping-helper. - Updated the /var/run paths in sllin-demo.service and associated start_lin_demo.sh script to quiet systemd warnings about /var/run usage. Bug-AGL: SPEC-3540 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ife02f75f57ac7bbdee6b02217e2ab657fe8c36e0
Diffstat (limited to 'recipes-kernel/sllin/sllin.bb')
-rw-r--r--recipes-kernel/sllin/sllin.bb7
1 files changed, 0 insertions, 7 deletions
diff --git a/recipes-kernel/sllin/sllin.bb b/recipes-kernel/sllin/sllin.bb
index 7c4313f1..0478b21a 100644
--- a/recipes-kernel/sllin/sllin.bb
+++ b/recipes-kernel/sllin/sllin.bb
@@ -18,7 +18,6 @@ SRC_URI_append = " \
file://0003-Allow-recent-kernels-newer-4.11.x-to-build.patch;pnum=2 \
file://0001-Disable-sllin-driver-debug-log.patch;pnum=2 \
file://sllin-demo.service \
- file://sllin-demo-virtual.service \
file://start_lin_demo.sh \
file://lin_config.conf \
"
@@ -30,22 +29,16 @@ SLLINBAUDRATE ??= "9600"
module_conf_sllin = "options sllin baudrate=${SLLINBAUDRATE}"
SYSTEMD_SERVICE_${PN} = "sllin-demo.service"
-SYSTEMD_SERVICE_${PN}-virtual = "sllin-demo-virtual.service"
do_install_append () {
install -d 644 ${D}/${bindir}
install -m 755 ${WORKDIR}/start_lin_demo.sh ${D}/${bindir}/start_lin_demo.sh
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/sllin-demo.service ${D}${systemd_system_unitdir}/
- install -m 0644 ${WORKDIR}/sllin-demo-virtual.service ${D}${systemd_system_unitdir}/
install -d ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/lin_config.conf ${D}${sysconfdir}/
}
-PACKAGES =+ "${PN}-virtual"
-
FILES_${PN} += "${bindir}/start_lin_demo.sh ${sysconfdir}/lin_config.conf"
-FILES_${PN}-virtual = "${systemd_system_unitdir}/sllin-demo-virtual.service"
-
RDEPENDS_${PN} += "lin-config"