summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/sllin/sllin.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-10-31 15:01:52 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-10-31 21:55:30 +0100
commitd30e570a35bf60b8c78b804608af2fe13a69e41d (patch)
tree31b28da2bb0af83d1d6149057eac07c9d465d061 /recipes-kernel/sllin/sllin.bb
parente2ea64fbb1ecade399397c8cdb01e91d6b83caee (diff)
Add package for sllin driver to image
The sllin driver is needed for the AGL demo unit to drive the actuator and fan. Change-Id: I76a8e7876148b6c2fcbc526a64a7ec132668c754 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-kernel/sllin/sllin.bb')
-rw-r--r--recipes-kernel/sllin/sllin.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/sllin/sllin.bb b/recipes-kernel/sllin/sllin.bb
new file mode 100644
index 00000000..eecd4394
--- /dev/null
+++ b/recipes-kernel/sllin/sllin.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "slLIN driver module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+inherit module
+
+DEPENDS = "virtual/kernel"
+
+SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https"
+SRCREV = "155d885e8ccc907a56f6c86c4b159fac27ef6fec"
+S = "${WORKDIR}/git/sllin"
+
+PV = "0.1+git${SRCPV}"
+
+SRC_URI_append = " \
+ file://0001_update_makefile.patch;pnum=2 \
+ file://0002_fix_null_operation_check.patch;pnum=2 \
+ file://0003-Allow-recent-kernels-newer-4.11.x-to-build.patch;pnum=2 \
+"
+
+