aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/sllin/sllin.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-11-06 16:14:57 -0500
committerScott Murray <scott.murray@konsulko.com>2019-11-06 21:08:14 +0000
commit3fe7f283824a7afb6ffe22a904d57b28a9b69a72 (patch)
tree4d556ba9486bc6ca7af6ed0169ea2ab402075093 /recipes-kernel/sllin/sllin.bb
parentc4f32fa3c22b15a513c5ba0907b1927f6db53a61 (diff)
Update LIN demo to use lin-config
Changes include: - Add patch to fix lin-config recipe build QA error. - Tweak lin-config recipe to install lin_config as executable. - Rework sllin-demo systemd unit and start_lin_demo.sh script to use lin_config with an appropriate configuration file that enables polling of the steering wheel adapter instead of just using ldattach. Bug-AGL: SPEC-2918 Change-Id: I3258b7e34cecbbb1cfb93ea6f63a44f0bbb2c06f Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-kernel/sllin/sllin.bb')
-rw-r--r--recipes-kernel/sllin/sllin.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-kernel/sllin/sllin.bb b/recipes-kernel/sllin/sllin.bb
index 6213fd96..0478b21a 100644
--- a/recipes-kernel/sllin/sllin.bb
+++ b/recipes-kernel/sllin/sllin.bb
@@ -19,6 +19,7 @@ SRC_URI_append = " \
file://0001-Disable-sllin-driver-debug-log.patch;pnum=2 \
file://sllin-demo.service \
file://start_lin_demo.sh \
+ file://lin_config.conf \
"
KERNEL_MODULE_AUTOLOAD_append = " sllin"
@@ -34,6 +35,10 @@ do_install_append () {
install -m 755 ${WORKDIR}/start_lin_demo.sh ${D}/${bindir}/start_lin_demo.sh
install -d ${D}${systemd_system_unitdir}
install -m 0644 ${WORKDIR}/sllin-demo.service ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/lin_config.conf ${D}${sysconfdir}/
}
-FILES_${PN}_append = " ${bindir}/start_lin_demo.sh"
+FILES_${PN} += "${bindir}/start_lin_demo.sh ${sysconfdir}/lin_config.conf"
+
+RDEPENDS_${PN} += "lin-config"