summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2016-12-20 21:34:46 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-22 15:29:37 +0000
commitaf4a22aeda5e5dfede3dd3f1a65165ccb5632ce0 (patch)
treeb0833207c9fdb09902a56f46cee78e717d918cef /recipes-kernel
parent6511c88c7e2a515441d22bd583b1386b104b93b5 (diff)
Support systemd services of MOST for CES2017 Demo
This change is for booting all stuff for MOST automatically after WindowManager launched. All services except insmod are in systemd user mode. Change-Id: I15043493c797511275e4f02173a85f06a7298ca0 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/aim-cdev/aim-cdev.bb8
-rw-r--r--recipes-kernel/aim-network/aim-network.bb8
-rw-r--r--recipes-kernel/aim-sound/aim-sound.bb8
-rw-r--r--recipes-kernel/aim-v4l2/aim-v4l2.bb8
-rw-r--r--recipes-kernel/hdm-dim2/hdm-dim2.bb8
-rw-r--r--recipes-kernel/hdm-i2c/hdm-i2c.bb8
-rw-r--r--recipes-kernel/hdm-usb/hdm-usb.bb8
-rw-r--r--recipes-kernel/mocca-usb/mocca-usb.bb8
-rw-r--r--recipes-kernel/mostcore/mostcore.bb8
9 files changed, 72 insertions, 0 deletions
diff --git a/recipes-kernel/aim-cdev/aim-cdev.bb b/recipes-kernel/aim-cdev/aim-cdev.bb
index b51fe2362..b43800ecf 100644
--- a/recipes-kernel/aim-cdev/aim-cdev.bb
+++ b/recipes-kernel/aim-cdev/aim-cdev.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
+ fi
+}
diff --git a/recipes-kernel/aim-network/aim-network.bb b/recipes-kernel/aim-network/aim-network.bb
index b51fe2362..ce3d76773 100644
--- a/recipes-kernel/aim-network/aim-network.bb
+++ b/recipes-kernel/aim-network/aim-network.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
+ fi
+}
diff --git a/recipes-kernel/aim-sound/aim-sound.bb b/recipes-kernel/aim-sound/aim-sound.bb
index b51fe2362..02d790770 100644
--- a/recipes-kernel/aim-sound/aim-sound.bb
+++ b/recipes-kernel/aim-sound/aim-sound.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
+ fi
+}
diff --git a/recipes-kernel/aim-v4l2/aim-v4l2.bb b/recipes-kernel/aim-v4l2/aim-v4l2.bb
index b51fe2362..123369601 100644
--- a/recipes-kernel/aim-v4l2/aim-v4l2.bb
+++ b/recipes-kernel/aim-v4l2/aim-v4l2.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
+ fi
+}
diff --git a/recipes-kernel/hdm-dim2/hdm-dim2.bb b/recipes-kernel/hdm-dim2/hdm-dim2.bb
index b51fe2362..d9cdf4d8c 100644
--- a/recipes-kernel/hdm-dim2/hdm-dim2.bb
+++ b/recipes-kernel/hdm-dim2/hdm-dim2.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
+ fi
+}
diff --git a/recipes-kernel/hdm-i2c/hdm-i2c.bb b/recipes-kernel/hdm-i2c/hdm-i2c.bb
index b51fe2362..6e51106b2 100644
--- a/recipes-kernel/hdm-i2c/hdm-i2c.bb
+++ b/recipes-kernel/hdm-i2c/hdm-i2c.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
+ fi
+}
diff --git a/recipes-kernel/hdm-usb/hdm-usb.bb b/recipes-kernel/hdm-usb/hdm-usb.bb
index b51fe2362..d8724d4f9 100644
--- a/recipes-kernel/hdm-usb/hdm-usb.bb
+++ b/recipes-kernel/hdm-usb/hdm-usb.bb
@@ -16,3 +16,11 @@ SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
+ fi
+}
diff --git a/recipes-kernel/mocca-usb/mocca-usb.bb b/recipes-kernel/mocca-usb/mocca-usb.bb
index 6f4e5861c..034585f14 100644
--- a/recipes-kernel/mocca-usb/mocca-usb.bb
+++ b/recipes-kernel/mocca-usb/mocca-usb.bb
@@ -12,3 +12,11 @@ SRCREV = "02ba272c0eb51b06160307b6cb71f91684772c8c"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "mocca_usb" > ${D}${sysconfdir}/modules-load.d/mocca_usb.conf
+ fi
+}
diff --git a/recipes-kernel/mostcore/mostcore.bb b/recipes-kernel/mostcore/mostcore.bb
index 3a2e1cfe7..f170c58db 100644
--- a/recipes-kernel/mostcore/mostcore.bb
+++ b/recipes-kernel/mostcore/mostcore.bb
@@ -16,3 +16,11 @@ SRCREV = "7850efa9077fa84536e0442c65d39a36e25e39d1"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+do_install_append () {
+ # modprobe automatically at boot
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf
+ fi
+}