summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-12-07 19:00:11 +0900
committerScott Murray <scott.murray@konsulko.com>2022-12-07 19:26:14 +0900
commit9d9c7970c89d2b43d9515db2e5fd1001026b0eb3 (patch)
tree17fdd8a47772898c3837d0ab19b480db5ae8f6ee /recipes-kernel
parentb7ea2af70b543fcea0f3c9a83cbd6b12c779b2d1 (diff)
Remove demo sllin configuration
Remove recipes providing sllin configuration for the full demo, as all LIN usage is being replaced with CAN. The recipes for the sllin driver and associated lin_config utility are kept for now in case there are external uses. Bug-AGL: SPEC-4635 Change-Id: I67b7acf5a8c3801cb1890ee27486080255252385 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/sllin/files/lin_config.conf10
-rw-r--r--recipes-kernel/sllin/files/sllin-demo.service12
-rwxr-xr-xrecipes-kernel/sllin/files/start_lin_demo.sh59
-rw-r--r--recipes-kernel/sllin/sllin-demo.bb29
4 files changed, 0 insertions, 110 deletions
diff --git a/recipes-kernel/sllin/files/lin_config.conf b/recipes-kernel/sllin/files/lin_config.conf
deleted file mode 100644
index 9775b8b3..00000000
--- a/recipes-kernel/sllin/files/lin_config.conf
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!--PCAN-LIN CT profile.-->
-<PCLIN_PROFILE Version="1">
- <LIN Group="2">
- <Scheduler_Entries Count="1">
- <!-- Poll steering wheel adapter at address 0x21 every 100 ms -->
- <Entry Time="100">33</Entry>
- </Scheduler_Entries>
- </LIN>
-</PCLIN_PROFILE>
diff --git a/recipes-kernel/sllin/files/sllin-demo.service b/recipes-kernel/sllin/files/sllin-demo.service
deleted file mode 100644
index e6af0be5..00000000
--- a/recipes-kernel/sllin/files/sllin-demo.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=LIN demo configuration
-ConditionPathExists=/dev/ttyUSB0
-
-[Service]
-Type=forking
-PIDFile=/run/lin_config/lin_config.pid
-ExecStart=/usr/bin/start_lin_demo.sh
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target
diff --git a/recipes-kernel/sllin/files/start_lin_demo.sh b/recipes-kernel/sllin/files/start_lin_demo.sh
deleted file mode 100755
index c97f0a2c..00000000
--- a/recipes-kernel/sllin/files/start_lin_demo.sh
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/sh
-
-# Attach serial LIN->CAN bridge and set up LIN polling
-if [ -c /dev/ttyUSB0 ]; then
- sleep 1
- /usr/bin/lin_config -m -c /etc/lin_config.conf -a sllin:/dev/ttyUSB0
- mkdir -p /run/lin_config/
- pidof lin_config > /run/lin_config/lin_config.pid
- sleep 1
-else
- ip link add dev sllin0 type vcan
-fi
-ip link set sllin0 up
-
-# Initialize HVAC controller
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 02A#
-usleep 100000
-cansend sllin0 02B#
-usleep 100000
-cansend sllin0 032#F0F8FFFFFFFFFFFF
-usleep 100000
-cansend sllin0 032#F0F8FFFFFFFFFFFF
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 030#
-usleep 100000
-cansend sllin0 02D#
-usleep 100000
-cansend sllin0 02C#
-usleep 100000
-cansend sllin0 02D#
-usleep 100000
-cansend sllin0 02C#
-usleep 100000
-
diff --git a/recipes-kernel/sllin/sllin-demo.bb b/recipes-kernel/sllin/sllin-demo.bb
deleted file mode 100644
index bd764bea..00000000
--- a/recipes-kernel/sllin/sllin-demo.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-DESCRIPTION = "AGL IVI demo slLIN driver configuration"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-inherit allarch systemd
-
-SRC_URI = " \
- file://sllin-demo.service \
- file://start_lin_demo.sh \
- file://lin_config.conf \
-"
-
-SYSTEMD_SERVICE:${PN} = "sllin-demo.service"
-
-do_install:append () {
- install -d 644 ${D}/${bindir}
- install -m 0755 ${WORKDIR}/start_lin_demo.sh ${D}/${bindir}/start_lin_demo.sh
- install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/sllin-demo.service ${D}${systemd_system_unitdir}/
- install -d ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/lin_config.conf ${D}${sysconfdir}/
-}
-
-FILES:${PN} += " \
- ${bindir}/start_lin_demo.sh \
- ${sysconfdir}/lin_config.conf \
-"
-
-RDEPENDS:${PN} += "lin-config"