summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/audiomanager-plugins
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2017-11-03 10:13:50 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-03 19:20:24 +0000
commit3294d066144cc61df3717af95bca8032f8386375 (patch)
tree13b0b3ac1dbe6342e9c7633f216d43a26948c3e0 /recipes-multimedia/audiomanager-plugins
parente96107e981c04b71e81986dc2528e06ae7515488 (diff)
Rework PulseAudio / audiomanager config setup to allow over-rides
Changes include: - Move from having PulseAudio configuration changes in the recipe bbappend as patches to using the .include directive in default.pa to pick up configuration fragments provided by other recipes. - Use virtual/pulseaudio-config to pick up the previously hard-coded configuration for enabling module-router.so, which is now provided by a new recipe that sets RPROVIDES appropriately. This allows over-riding the desired configuration if needed. - Switch the audiomanager-plugins-config dependency to using virtual/audiomanager-plugins-config so that it can be over-ridden with PREFERRED_PROVIDER if needed. Bug-AGL: SPEC-1025, SPEC-1026, SPEC-1027 Change-Id: Ifdf16871cddc2bec7761b8c63239623b63c9e984 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-multimedia/audiomanager-plugins')
-rw-r--r--recipes-multimedia/audiomanager-plugins/audiomanager-plugins_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-multimedia/audiomanager-plugins/audiomanager-plugins_git.bb b/recipes-multimedia/audiomanager-plugins/audiomanager-plugins_git.bb
index c81f414b..9b099ebc 100644
--- a/recipes-multimedia/audiomanager-plugins/audiomanager-plugins_git.bb
+++ b/recipes-multimedia/audiomanager-plugins/audiomanager-plugins_git.bb
@@ -3,7 +3,6 @@ HOMEPAGE = "http://projects.genivi.org/audio-manager/home"
LICENSE = "MPLv2"
SECTION = "multimedia"
DEPENDS = "audiomanager libxml2 dbus pulseaudio"
-RDEPENDS_${PN} = "audiomanager-plugins-config"
LIC_FILES_CHKSUM = "file://PluginControlInterfaceGeneric/LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
@@ -57,3 +56,5 @@ do_install_append() {
rm -rf ${D}${sysconfdir}/audiomanager/control/*.xml
rm -rf ${D}${sysconfdir}/audiomanager/control/customtypes.xsd
}
+
+RDEPENDS_${PN} = "virtual/audiomanager-plugins-config"