summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/audiomanager/audiomanager_7.4.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-15 14:47:00 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-06-05 15:11:36 +0200
commitb6852864508358930586e083e72cd2912af68674 (patch)
tree4029e33f00bbd0247524d03f7c1689672d85ef9b /recipes-multimedia/audiomanager/audiomanager_7.4.bb
parentfab778caff2041794814df54b51893965381aa66 (diff)
3rd part of the layer/profile rework [2/2]
This is the last part of the layer rework series. Notable changes are: - move demo specific recipes to the demo (dlt, web-runtime mocca-usb) - wayland-ivi-extension moved to the meta-agl-demo layer for now. - web-runtime moved here (from appfw layer to allow console-only builds with appfw) - adapted packagegroups and agl-features v2: squashed with commit on sandbox to form single commit (tnx, Scott) v3: inclusion of old packagegroup-agl-image-ivi (TODO: refactor and include in profile packagegroups. Tnx, Stephane) v4: base packagegroup-agl-demo-platform on packagegroup-agl-profile-graphical-qt5 v5: fix MOST_DRIVERS_append (disable due to FTBS) v6: re-add RDEPENDS for virtual/pulseaudio-config Bug-AGL: SPEC-145 Bug-AGL: SPEC-1422 Change-Id: I20bd5b9a957ea54a7ecd08bd4f8b99a32266c9c8 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-multimedia/audiomanager/audiomanager_7.4.bb')
-rw-r--r--recipes-multimedia/audiomanager/audiomanager_7.4.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes-multimedia/audiomanager/audiomanager_7.4.bb b/recipes-multimedia/audiomanager/audiomanager_7.4.bb
new file mode 100644
index 00000000..15eb3625
--- /dev/null
+++ b/recipes-multimedia/audiomanager/audiomanager_7.4.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "GENIVI Audio Manager"
+HOMEPAGE = "http://projects.genivi.org/audio-manager/home"
+LICENSE = "MPLv2"
+SECTION = "multimedia"
+DEPENDS = "dbus dlt-daemon systemd"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=f164349b56ed530a6642e9b9f244eec5"
+
+SRC_URI = " \
+ git://github.com/GENIVI/AudioManager.git;protocol=https;branch=master \
+ file://audiomanager.service \
+"
+RDEPENDS_${PN} = "audiomanager-plugins module-router"
+SRCREV = "daf851ee7a41d1b0572c0c95e15f61e427ce97f1"
+
+S = "${WORKDIR}/git"
+inherit cmake systemd
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "audiomanager.service"
+SYSTEMD_AUTO_ENABLE = "enable"
+
+EXTRA_OECMAKE = " \
+ -DWITH_TESTS=OFF \
+ -DWITH_DOCUMENTATION=OFF \
+ -DWITH_DLT=ON \
+ -DWITH_TELNET=OFF \
+ -DWITH_SYSTEMD_WATCHDOG=ON \
+ -DGLIB_DBUS_TYPES_TOLERANT=ON \
+ -DWITH_CAPI_WRAPPER=OFF \
+ -DWITH_DBUS_WRAPPER=ON \
+ -DWITH_SHARED_UTILITIES=ON \
+ -DWITH_SHARED_CORE=ON \
+"
+
+FILES_${PN} = " \
+ ${bindir}/AudioManager \
+ ${libdir}/libAudioManagerCore.so.7 \
+ ${libdir}/libAudioManagerCore.so.7.4 \
+ ${libdir}/libAudioManagerCore.so.7.4.12 \
+ ${libdir}/libAudioManagerUtilities.so.7 \
+ ${libdir}/libAudioManagerUtilities.so.7.4 \
+ ${libdir}/libAudioManagerUtilities.so.7.4.12 \
+ ${systemd_unitdir}/audiomanager.service \
+"
+
+FILES_${PN}-dev = " \
+ ${includedir}/audiomanager/* \
+ ${libdir}/cmake/* \
+ ${libdir}/pkgconfig/* \
+ ${libdir}/libAudioManagerCore.so \
+ ${libdir}/libAudioManagerUtilities.so \
+"
+
+do_install_append() {
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/audiomanager.service ${D}${systemd_unitdir}/system/
+}