summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:58:45 -0400
committerScott Murray <scott.murray@konsulko.com>2021-11-17 14:20:22 -0500
commit12ad591d3038db609db5290d8bbe809a34c743de (patch)
treedbbcc9a44134a012f531d48132c8803c3940bfa2 /recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
parent88c424f8b8c78dfc5520ea9be1866027df4735b8 (diff)
This is effectively a manual cherry-pick and squash of commits: 4249268041b879b3d2bae338d5de88f4f2d54b26 07f4ab8c2833ae5377b97cc9e3820bed67e539d0 from the master branch with additional review and fixups. The intent of these changes is to minimize the effort to backport fixes from the master branch, which has been updated in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4144 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I3b47f1b7d62038b314a17763d24a64f6d4e15e72
Diffstat (limited to 'recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend')
-rw-r--r--recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend16
1 files changed, 8 insertions, 8 deletions
diff --git a/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend b/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
index b47b2796..5208933d 100644
--- a/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
+++ b/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
@@ -1,7 +1,7 @@
# Disable everything but the roygalty-free formats
PACKAGECONFIG = "ogg flac wave m3u pls jpeg png"
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI += "file://lightmediascanner.service \
file://plugin-ogg-fix-chucksize-issue.patch \
@@ -9,15 +9,15 @@ SRC_URI += "file://lightmediascanner.service \
file://dbus-lightmediascanner.conf \
"
-CFLAGS_append = " -D_FILE_OFFSET_BITS=64"
+CFLAGS:append = " -D_FILE_OFFSET_BITS=64"
inherit systemd
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "lightmediascanner.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "enable"
+SYSTEMD_SERVICE:${PN} = "lightmediascanner.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "enable"
-do_install_append() {
+do_install:append() {
# Install LMS systemd service
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
@@ -28,7 +28,7 @@ do_install_append() {
install -m 0644 ${WORKDIR}/dbus-lightmediascanner.conf ${D}/etc/dbus-1/system.d/org.lightmediascanner.conf
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_system_unitdir}/lightmediascanner.service', '', d)} \
"
@@ -36,7 +36,7 @@ EXTRA_OECONF = "--enable-static --with-dbus-services=${datadir}/dbus-1/system-se
PACKAGECONFIG[mp4] = "--enable-mp4,--disable-mp4,libmp4v2"
# add support MP3 because of the format of music files for AGL CES/ALS2017 Demo
-PACKAGECONFIG_append = " id3 mp4"
+PACKAGECONFIG:append = " id3 mp4"
# add required character sets for id3 tag scanning
-RDEPENDS_${PN}_append = " glibc-gconv-utf-16 glibc-gconv-iso8859-1"
+RDEPENDS:${PN}:append = " glibc-gconv-utf-16 glibc-gconv-iso8859-1"